Forum Visual Studio
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Problem with PCL Support after update

pmourfieldpmourfield USUniversity

I have a project that used a PCL which worked fine until I updated to the new releases in the Stable channel today (7/24). Now I'm getting this error with the PCL: Assembly not available for .NETPortable 4.0 Profile 1 Profile(in Mono 3.2.0)

Any thoughts on what am I doing wrong?


  • Yes I have the same thing

  • AlisonKeenAlisonKeen AUMember

    +1 here.

    PCL Project that was working fine pre-update now won't compile - Error CS0518 "The Predefined object System.<Object, Value Type etc> is not defined or imported"

    And just to clarify, Yes, the References still say System, System.Core and System.XML

    Did that update just do something evil to the underlying mono install or something?

  • AlisonKeenAlisonKeen AUMember

    Also, for what it's worth:

    $ mono --version
    Mono JIT compiler version 3.2.0 ((no/7c7fcc7 Tue Jul 23 19:59:39 EDT 2013)
    Copyright (C) 2002-2012 Novell, Inc, Xamarin Inc and Contributors.
    TLS: normal
    SIGSEGV: altstack
    Notification: kqueue
    Architecture: x86
    Disabled: none
    Misc: softdebug
    LLVM: yes(3.3svn-mono)
    GC: sgen

    I'm using Xamarin.Mac (Xamarin Studio 4.0.10 build 7) on OSX 10.8.2

  • SatheeshSatheesh USMember

    Even i faced the same errors since morning.
    I have changed the .Net Runtimes to mono 2.10.12 framework (Xamarin Studio->Projects->.Net Runtimes) as default for now, until the xamarin resolves the issue.

  • mhutchmhutch USMember, Xamarin Team Xamurai

    We are not currently shipping PCL reference assemblies on MacOS. You can build the PCL project on Windows and copy the resulting assembly to MacOS, or manually install the PCL reference assemblies into:


    This directory is equivalent to this directory on Windows:

    C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETPortable
  • JasonFamularoJasonFamularo US ✭✭
    edited July 2013

    @mhutch Are you saying we can copy the contents of

    C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework.NETPortable



    and it should work? Or am I misunderstanding (as it is not working for me)

  • mhutchmhutch USMember, Xamarin Team Xamurai

    What is not working?

  • All the built-in .NET types aren't recognized (I'm trying to compile a Profile158 PCL project on the Mac). Worked in the alpha, updated to stable. As I am understanding it, Mono 3.2.0 doesn't have the PCL support on the Mac yet. Did 3.1.2?

  • mhutchmhutch USMember, Xamarin Team Xamurai

    Mono 3.2 does not have out-of-the-box support for compiling PCL assemblies, as PCL reference assemblies are not included yet. However, it does have full support for consuming PCL assemblies, which is new in this release.

    What do you mean by "not recognized"? Maybe you're see bug 13221 which causes syntax highlighting and code completion to fail unless you add explicit assembly references.

  • GabiGabi DEMember ✭✭

    When will this work in Xamarin.iOS for Visual Studio? If I try to consume a PCL (Profile 78) here, it says e.g.

    "The type 'System.Object' is defined in an assembly that is not referenced. You must add a reference to assembly 'System.Runtime, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'."

    In Xamarin.iOS on Mac it works just fine. I am using the latest stable versions from yesterday.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    We'll be doing a Mono 3.2.1 release next week (going into Beta tonight?) which will fix PCLs.

  • GuillermoGutierrezGuillermoGutierrez ESMember ✭✭✭

    Rolling back to Mono 3.1.2 does the trick. See this post.

    Very strange that worked in Alpha and doesn't work in Stable channel ಠ_ಠ

  • Imran-AAJTechImran-AAJTech USMember

    Reverting back to Mono 3.1.2 will fix this issue temporary. In Xamarin Studio-> Preferences -> Projects -> Select Mono 3.1.2 and mark it as default.

  • LuigiSaggeseLuigiSaggese ITDeveloper Group Leader ✭✭

    +1 same problem! Quote Guillermo "Very strange that worked in Alpha and doesn't work in Stable channel ಠ_ಠ"

    @Xamarin why that doesn't happens in alpha?
    @Xamarin when is planned to solve that problem?

  • JeffKesselmanJeffKesselman USMember

    The solution for me was to install the Mono 3.4.0 MDK not the MRE

    Apparently only the MDK has PCL support

Sign In or Register to comment.