Forum Visual Studio


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Xamarin iOS DocSync not working

MarkGentileMarkGentile USMember
edited March 2016 in Visual Studio

After the most recent Xamarin update, Xamarin iOS DocSync displays an alert that an update is available. When I open documentation manager, I see all three tasks (Downloading, Extracting, Merging) that spin forever and never complete. On the bottom status bar an error is displayed, "DocSet folder not found in c:\users\mark\appdata\local\temp\xamarin..." (the path is truncated). Any help would be appreciated. Thanks. (Mark)


Best Answer


  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭✭


  • OlafBarteltOlafBartelt DEMember ✭✭

    Same here.

  • BrunoFreitas.2621BrunoFreitas.2621 PTMember ✭✭

    same here

  • DeanChalkDeanChalk GBMember

    BINGO! - thanks

  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭✭

    @JoshuaCarter Your tip appears to be working. Now at least the 'download progress' %age is moving...

    But when I tried to just delete that folder the system asked me if it can be deleted permanently as some of the names are too long for the Recycle Bin. Probably this exception was not handled properly and hence it got hung.

  • MarkGentileMarkGentile USMember

    Thanks @JoshuaCarter! That did the trick for me as well.

  • jelopezjelopez ESMember

    Thnaks @JoshuaCarter It worked!

  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭✭

    I have to apply @JoshuaCarter tip today... again...

  • ArchitektArchitekt USMember ✭✭

    This isn't working for me. When I look in that directory, %localappdata%\Temp, there isn't a subfolder named "Xamarin". I tried deleting everything in there, regardless. Then I exited docsync and restarted visual studio. Upon trying to update, the same problem happens: sits at 100% downloaded and the 3 wheels spin forever. Any other solution to try?

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    In case it might be a useful cross-reference, one other possible complication with the DocSync process is:

    Bug 40754 - DocSync fails or waits indefinitely during "extracting" if username contains spaces

  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭✭

    In my case it failed even if my user name didn't have any spaces. Actually the 'Users' directory was created just using the first 5 characters of my username on Windows.

Sign In or Register to comment.