No intellisense in .cs files in Android project

MichaelRumplerMichaelRumpler ✭✭✭✭✭ATMember ✭✭✭✭✭

When I open .cs files in VS2015, then the IDE displays just "Miscellaneous Files" in the top left dropdown list instead of the project name and I have no intellisense.

This happens mostly in Android projects, but I think I also saw it in iOS once. In the past I had this every now and then, but restarting VS, cleaning the solution or deleting the .vs folder always fixed it. Not anymore. I only worked in iOS the last week, but when I tried to continue with Android yesterday, this bug was consistent.
I had XVS 4.0.1.96, updated to 4.0.1.145 and now 4.1.0.87, rebooted both the Windows machine and the Mac build host, deleted all bin, obj and .vs folders, but nothing works. It does seem to depend on the solution. When I open a different solution, then it works. But I don't know what else I can delete.

Did anybody else experience this and/or knows how to get it going again?

Posts

  • MichaelRumplerMichaelRumpler ✭✭✭✭✭ ATMember ✭✭✭✭✭
    edited March 2016

    There's already a bug for this filed in June 2015 - 9 months ago.

  • AllisterAllister ✭✭ USMember ✭✭
    edited March 2016

    Yeah it comes and goes for me too, I'm trying to remember how I got it back last time(s), as I'm pretty sure my entire Android project aren't miscellaneous files :-)
    Thats right, I delete the projects XXXXX.Droid.csproj.vspscc file, now the files are being recognised again.
    good old regression bugs :-)

  • NelsonthomaSNelsonthomaS INMember

    Same comes for me too. Donno what to do. Tried restarting VS and closed and open the project again. Android project got the problem.

  • MichaelRumplerMichaelRumpler ✭✭✭✭✭ ATMember ✭✭✭✭✭

    Brendans workaround from the linked bug works for me most of the time.

    Possible workaround

    In some of my quick tests, it appeared that the following steps improved the chances that the Android project would behave as expected:

    1. Build the Android app project.
    2. Close and then re-open the solution.
  • AdamvandenHovenAdamvandenHoven USMember

    I just had this problem and I ended up here trying to find the solution. In trying the possible work around recommended by Michael Rempler, I uncovered an additional possible cause that you might want to look out for.

    In my case I had a file in the assets directory (marked with the AndroidAsset build action) that I forgotten to add to the repository. Some branch switching and then when I go back to it the project has the file listed and the file doesn't exist. Resolving the missing file, which I discovered by trying to build, solved the problem

  • EmreErtugrul80EmreErtugrul80 ✭✭ USMember ✭✭

    Hey, I have this issue now. Intellisense is broken exactly as the first post and I have tried everything but couldn't get it to work. Rebuilding & restarting does'nt work, I have no missing files, I'm lost on what else to do. It's only problem this one solution though..

  • MichaelRumplerMichaelRumpler ✭✭✭✭✭ ATMember ✭✭✭✭✭

    You must not restart VS.

    You should

    • build your Android project
    • close the solution but keep VS open
    • and then reopen the solution in the same VS instance.
  • Matt_PerleyMatt_Perley ✭✭ CAMember ✭✭

    i did not notice any notification as to whether or not this bug actually was fixed or not. the fix posted worked--> https://bugzilla.xamarin.com/show_bug.cgi?id=50914 <-- but is not something i want to go through every time this happens (which is to often). when the android files are not recognized it prevents my location service working.

    before fix:
    Location location for example would = null;

    after fix:
    Location location for example would = 128.000, 77.000.

    thank you @MichaelRumpler for providing link to bugzilla && fix!

Sign In or Register to comment.