Getting build errors for xib files

AlexanderArgutinAlexanderArgutin USMember
edited March 2016 in Xamarin.iOS

Hello,

I'm very new to xamarin studio and iOS. I'm trying to build an existing xamarin app, but getting the following error. Not sure why there is a problem with 9.2 simulator, because I can start that simulator from Xcode. Also it is strange: the compiler complains about 9.2 even though I set debug target to different platforms. I also noticed that if I remove this xib from the project, the build will break on the next xib with the same error message. Any suggestions?

MyForm.xib: Error: 2016-03-10 22:41:50.799 ibtoold[2545:90532] [MT] IBPlatformTool: *** Failed to launch tool with description System content 1x for IBCocoaTouchFramework-NineOneAndLater w/ default fidelity: Failed to find or create execution context for description System content 1x for IBCocoaTouchFramework-NineOneAndLater w/ default fidelity: Failed to find a suitable device for the type SimDeviceType : com.apple.dt.Xcode.IBSimDeviceType.iPad-1x with runtime SimRuntime : 9.2 (13C75) - com.apple.CoreSimulator.SimRuntime.iOS-9-2 (Failure reason: Failed to create new simulator device that matches SimDeviceType : com.apple.dt.Xcode.IBSimDeviceType.iPad-1x for runtime SimRuntime : 9.2 (13C75) - com.apple.CoreSimulator.SimRuntime.iOS-9-2 (Unable to determine SimDeviceSet, set_path=/Users/myuser/Library/Developer/Xcode/UserData/IB Support/Simulator Devices)): Unable to determine SimDeviceSet, set_path=/Users/myuser/Library/Developer/Xcode/UserData/IB Support/Simulator Devices
2016-03-10 22:41:59.504 ibtoold[2545:90532] [MT] IBPlatformTool: Wrote failed marshalling request diagnostics to path: /var/folders/cq/8z_k09h10hx02z7wz1l7zrgm0000gr/T/IB-agent-diagnostics_2016-03-10_22-41-58_828000 (MyProject)

Best Answer

Answers

  • Easy solution:
    I use CleanMyMac for clear Xcode cache.
    This resolve problem

  • 15mgm1515mgm15 USMember ✭✭✭✭

    Restart the mac worked for me.

  • AdrianSalazarAdrianSalazar USMember ✭✭

    @AleksandrAlekseev said:
    Easy solution:
    I use CleanMyMac for clear Xcode cache.
    This resolve problem

    Thanks, with this I will solve it.

  • DenisGordinDenisGordin RUMember ✭✭
    edited August 2018

    Deleting ~/Library/Developer/Xcode/DerivedData/[your app folder] solves the problem.
    It is unnecessary to clean whole "XCode cache"

Sign In or Register to comment.