Forum Visual Studio

"Detecting Installed Packages" never ends on latest Xamarin Studio

After updating to the latest level of Xamarin Studio, whenever I try to "Upload to Device", XS hangs on "Detecting Installed Packages".

How do I fix this?

Regards,
Jim

Answers

  • Curious behaviour.

    I left my laptop at "Detecting Installed Packages" and 20minutes later it installed the app on my Android device.

    So I tried it again, and the same thing happened.

    Nothing has changed on the Android device (5.1.1) or the USB cable.

    This started before I upgraded XS but continues after the update.

    Jim

  • I am experiencing this issue (freezing with the message "Detecting Installed Packages") debugging a native Android app on a Samsung S7 and don't know where to begin in terms of resolving it. Debugging worked previously for a month or two with periodic issues (freezing on installation of app for debugging) which were resolved by restarting Xamarin Studio (mac version) and/or restarting the computer. With the current issue, I have tried those options and read dozens of forum postings on this issue and don't know where to go from here. Also, my emulators one by one have stopped working, though one is left so I can do minimal debugging, but I really need to be able to debug on my device to test and develop properly. Please help if you are able to.

    Thanks,
    Scott

  • Randomly everything started working again.
    Here is what I tried:
    1. Manually deleting the Mono shared runtime app from my App Manager (this did not help)
    2. Installing other Xamarin apps to see if my phone was broken (from the play store worked, only after phone restart, and from Xamarin studio did not work)
    3. Testing out deployment (via the debugger) of my app AND a simple demo app from Xamarin Studio to an identical phone. The demo app MyShoppe worked. My app did not run, though it deployed (which was more than what was happening with my phone). It crashed immediately upon launch with no breakpoints being hit.
    4. Copying the app source code and upgrading my packages (that caused MAJOR problems)
    5. Returning to my original app and fixing warnings (don't think this had relevance, but I was running out of options)
    6. Sleeping on it
    7. In the morning, somehow deployment again worked and like the identical phone, the app crashed immediately upon launching (without hitting breakpoints)
    8. I went in and turned off the Fast Deployment and Shared Runtime in the Project's options.
    9. Deployment worked.

    Other notes of possible relevance, the day before these issues:
    1. I updated Xamarin studio to the newest stable channel
    2. Facebook and Oculus and Oculus Home did automated updates (on my phone)

    Not sure this comment will be of much help, but as of now I don't need assistance with this issue.

  • HassanJawedHassanJawed USUniversity ✭✭

    Any solution to fix this issue?

    I updated XS yesterday
    Here are current version numbers

    Xamarin Studio Community
    Version 6.3 (build 863)

    Xamarin.Android
    Version: 7.2.0.7 (Xamarin Studio Community)

    Since then, whenever I try to run my project on LG G3 it stuck at "Detecting Installed Packages" message
    I tried uninstalling all Xamarin related packages and my app as well but still no luck.

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    @HassanJawed

    Did you try cleaning and rebuilding your project, including deleting all of the bin and obj folders in your solution?

  • HassanJawedHassanJawed USUniversity ✭✭

    Yeah I did now, but it still stuck at the same spot.

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    @HassanJawed

    Can you try turning off the "Fast Deployment" option in the Project Options -> Android Build page? Or turning it on if it was off? Can you deploy, edit, and redeploy a new android project from template? Or does this issue seem specific to one project?

  • HassanJawedHassanJawed USUniversity ✭✭

    I tried to install XWeather with both Fast Deployment enabled and off but XS always stuck at "Detecting installed Packages".

    Last command in XS logs for Android Tools is this

    [2017-04-17 17:26:17.0] DEBUG: RunShellCommand: am broadcast -a "mono.android.intent.action.PACKAGE_VERSIONS" -e "packages" "Mono.Android.DebugRuntime,Mono.Android.Platform.ApiLevel_25,com.xamarin.xweather" -n "Mono.Android.DebugRuntime/com.xamarin.mono.android.PackageVersions"

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    @HassanJawed

    Thanks for the info. I just did a test and I was able to install and run the XWeather app using the source code downloaded from https://github.com/colbylwilliams/XWeather/tree/master (master branch). I loaded the solution into Xamarin Studio and deployed the Android app to a Google emulator without issue. Can you try the following things?

    1. Uninstall any existing version of the XWeather app from your device. Try uninstalling from the Settings -> Apps page rather than from the apps screen.
    2. Uninstall the Mono Shared Runtime from Settings -> Apps
    3. Uninstall any packages named Xamarin.Android API-XX Support from Settings -> Apps
    4. You may need to update your Android SDK
      a. Open Xamarin Studio
      b. Open the Android SDK Manager (Tools -> SDK Manager)
      c. Install offered updates / new packages
  • HassanJawedHassanJawed USUniversity ✭✭

    I tried on another device which is One Plus XS able to run XWeather without any hassle. But on LG G3 it always stuck on "Detecting installed Packages" I tried uninstalling all packages on the phone but still no luck.
    Moreover, Android sdk and XS is updated as well

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    Can you install other apps on that device (LG G3)?

  • HassanJawedHassanJawed USUniversity ✭✭

    Yes I can install apps from Android Studio, adb (using terminal) and Google play.

  • I have the same issue.
    If I type the command using the ADB shell, then the "am broadcast" call never returns.

    Rebooting the device helped although all the "am broadcast" commands are very slow. (~15 sec for one call, you can see this when output is diagnostic)
    I have a Samsung A3 which just was updated to Android 7 some days ago.

  • LucaPanellaLucaPanella USMember ✭✭

    I have the same issue, detecting installed packages runs forever! :(

  • EdHubbellEdHubbell USMember ✭✭

    Same problem here on a Pixel. Just adding my post to the forum so when a real workaround shows up I'll get some kind of notification. I've deleted everything I can think of from the phone. Not ready to do a factory reset just yet.

    A spare Pixel that I have lying around works just fine. So it seems to be that some file or something gets on the Android system and that makes Detecting Installed Packages run infinitely.

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    In another thread:

    @EdHubbell said:
    There was a workaround that works for my phone (today) in another thread. TLDR: Killing the Google app via a Force Stop seems to allow things to install again.

    https://forums.xamarin.com/discussion/97585/deploy-hangs-on-detecting-installed-packages#latest

  • Hy there,
    I still have this error, when deploying an Xamarin Forms android application to my samsung S10.

    IDE: Rider or Visual Studio -> on both
    C#8,
    Xamarin.Forms 4.8.0.1687
    Xamarin.Essentials 1.4.0
    JetBrains Rider 2020.2.4

    Build #RD-202.7660.16, built on September 30, 2020
    Runtime version: 11.0.8+10-b944.34 amd64
    VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
    .NET Framework 4.0.30319.42000
    Windows 10 10.0
    GC: ParNew, ConcurrentMarkSweep
    Memory: 1450M
    Cores: 8

    ...
    0>Touching "obj\Debug\100\android_debug_keystore.flag".
    Target _Sign:
    0>Skipping target "_Sign" because all output files are up-to-date with respect to the input files.
    Target _Upload:
    0>Detecting installed packages...

    The workaround does not work. I removed the app from my smartphone, still no luck
    I tried the following:

    • restart laptop
    • restart phone
    • stop google app
    • deleted bin and obj folder, project clean, project rebuild

    The problems comes and goes randomly (had it about 3 times in the last 5 month)

  • stuffbdstuffbd Member

    Same here just started after i installed xf5.0. rolled back to 4.8 problem still persists. Only for physical devices, emulator deploys ok. Doesn't mater what project i open the result is the same.

Sign In or Register to comment.