dSYM doesn't contain debug symbols

Mohib.ShethMohib.Sheth Mohib ShethCZMember ✭✭

Any zip file we upload containing the dSYM file, we always get the error "dSYM doesn't contain debug symbols"

This has started happening very recently and was working fine before. Has something changed on the server? How do we fix this (if its something we have to do)?

Posts

  • MichalHrubyMichalHruby Michal Hruby GBXamarin Team Xamurai

    Hi, yes, until last week we didn't detect upfront if the dSYM is stripped, now we do. Make sure your release builds do not strip the native debug information. Still, this only affects non-managed exceptions, dSYMs aren't necessary for managed ones.

  • Mohib.ShethMohib.Sheth Mohib Sheth CZMember ✭✭

    Why aren't these changes informed to the customers? Do we have to always stumble upon an issue and then fumble around for solutions?

    Coming back to the issue in question, you are asking me to disable an option which Xamarin enables by default for release builds?

    We tried building our app with the option "Strip native debugging symbols" enabled and again with the option disabled and we don't see any change to the size of the dSYM. Disabling the option infact increases the IPA file size by about 35% and we don't understand how this affects the dSYM upload since the dSYM file is unchanged.

    Could you please clarify a proper solution?

  • BobisbackBobisback Sean Hoffman USUniversity ✭✭

    I need a solution to this as well.

    It was working fine for the first two builds we did to testflight. Now for some reason it is saying there is no debug information in the dsym file. We have not changed anything in fact I did the builds within 10mins of each other and I only changed the build number from 12 to 13. So why would this all of a sudden change??

  • Mohib.ShethMohib.Sheth Mohib Sheth CZMember ✭✭
    edited May 2016

    @Bobisback We have realized that the "Archive" option in XS messes up the DSYM for some reason. If you are using "Archive" to create your final ipa to upload to TestFlight, do this:

    1) Select the Build Type (i.e AppStore/Ad-Hoc/etc)
    2) Do a build (this will create IPA + DSYM files in the bin/BuildType directory
    3) Make a copy of the DSYM file. This file is correct and you can upload to Insights.
    4) Use the "Archive" option to create the final IPA file to upload to TestFlight. Don't use the DSYM file created after using the "Archive" option because its incorrect (you can notice the difference in the size clearly)

    I am going to submit a bug report for this in a while.

  • BobisbackBobisback Sean Hoffman USUniversity ✭✭
    edited May 2016

    I am using visual studio to make my release builds. For some reason sometimes it builds the right dsym file and other times it does not. For instance just after I posted last I build the same project again no changes and that time it had the debug symbols in it. Yet today just now did another build and now it does not have debug symbols in it.

    Very annoying.

    P.S just built it again and now I have debug symbols....

  • Mohib.ShethMohib.Sheth Mohib Sheth CZMember ✭✭

    @Bobisback I created a bug report for this at https://bugzilla.xamarin.com/show_bug.cgi?id=41231

    Could you add your observations there?

  • Simon.5621Simon.5621 Simon USMember ✭✭

    Building after deleting the Ad-Hoc Folders, both on Windows VS and the Mac-Build-Server, solved it for me.

  • RonRatzlaffRonRatzlaff Ron Ratzlaff USMember
    edited November 2016

    Did anyone ever find a solution to this? This is happening for me on XS 6.1.1 (build 15). I see that the bug that was logged never got resolved and was closed due to lack of response. @Mohib.Sheth

  • Mohib.ShethMohib.Sheth Mohib Sheth CZMember ✭✭

    @RonRatzlaff No, we have been using the workaround since then. I never got around to creating a sample for this as requested but I also think they are just lazy. They could have done it easily since its not project specific. They can just take any sample and give it a try, won't take them more than a few minutes.

    If you can provide them with the requested details including the logs & a sample, maybe they will fix it.

  • LesterMeeksLesterMeeks Lester Meeks USMember ✭✭

    This just started happening to me again. Had to move to using the work around. the DSYM file in the normal build is 120MB the one with the archive is 30KB. Don't know what changed but sometime last week or so things started acting up.

  • ALEXEYSUBBOTAALEXEYSUBBOTA ALEXEY SUBBOTA RUMember ✭✭

    It is july 2017 and еру bug hasn't been fixed yet! Ugliness!

Sign In or Register to comment.