Getting Started with AWS Cognito

I've decided to give Xamarin another shot (tried it out a while back, but didn't really need it for that project).

I set up a Xamarin.Forms project and I'm all setup with my AWS resources. Now Amazon say they support Xamarin. But... when I get to this step:

http://docs.aws.amazon.com/mobile/sdkforxamarin/developerguide/setup.html#step-4-install-the-sdk-xamarin

It doesn't work. Here's the error I get:

Could not install package 'Microsoft.Bcl.Build 1.0.14'. You are trying to install this package into a project that targets 'MonoAndroid,Version=v6.0', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.

I'm new to both Xamarin and C#. So I'm not exactly sure what I'm dealing with here.

Thanks for any help.

Tagged:

Answers

  • AdamPAdamP AUUniversity ✭✭✭✭✭

    @RaphaelTitsworth-Morin.3500 - Microsoft.Bcl.Build should work with Xamarin.Android, I have installed it in the past many times. The only things I could recommend.

    1. Make sure you NuGet Package Manager is up to date.
    2. Upgrade Xamarin Forms NuGet Package

    Thats all I could find from people who have had similar issues.

  • NicoleTedescoNicoleTedesco USMember ✭✭

    I installed the Microsoft.Bcl.Build packages explicitly in all platforms. That worked, probably because I obtained the latest version. I then returned to the Amazon SDK packages and installed them in the missing platforms. That worked. Crisis averted.

Sign In or Register to comment.