Failed to resolve assembly: PLCrashReporterUnifiedBinding

Hi,

I have a Xamarin Forms Project that was working fine the last days.

But it seems I did a huge mistake! I cleaned my project!
Since then I'm getting the following error message when I try to run my iOS app:
MTOUCH: error MT2002: Failed to resolve assembly: 'PLCrashReporterUnifiedBinding, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'

I can't figure out how to solve that issue. The only hint the documentation gives is:
This seems to be a problem with your iOS installation. Try to reinstall Xamarin iOS.

I did. And I reinstalled Xamarin Studio! Nothing worked.

How to fix that problem?

Greeting

Posts

  • DavidRihaDavidRiha USMember ✭✭

    I fixed it by removing and adding again the Xamarin.Insights nuget.

  • JohnHardmanJohnHardman GBUniversity ✭✭✭✭✭

    @DirkDenzer - From a problem I hit recently, I'd say that removing and replacing either the Xamarin.Insights or the HockeyApp NuGet packages should solve it. Don't add both though, as you'll hit the problem I did.

    As an aside, I would recommend cleaning your project regularly. That way, you will find out if there are issues with your build sooner rather than later. When I set up automated build processes, the CI build process may just do a Build, but a daily build and a release build would always do a Rebuild All (actually, I wipe down the folder structure completely and get all files required by the build out of version control again in order to ensure no stray files are being picked up).

  • DirkDenzerDirkDenzer USMember

    Hi guys,

    thanks for the responses, perhaps it will help someone in the future!
    But for me, I don't even remember how but I solved that a year ago.

    Greetings

  • NateVargheseNateVarghese USUniversity ✭✭

    Sadly, the normal reinstall trick doesn't work anymore. I've reinstalled the insights nuget a few times with no success. Anyone have another idea?

Sign In or Register to comment.