Forum Xamarin.Android

Cannot change icon from default Xamarin icon.

Hey.

So i have a HUGE problem, i have created an app in Xamarin.Forms.
The time has now come to change the icon, to one I have designed, but the problem is that I cannot get the app to change from the default Xamarin icon.

I have tried everything, but it simply will not change.
Any ideas?

Tagged:

Best Answer

Answers

  • JimBennettJimBennett GBXamarin Team, Insider, University, Developer Group Leader ✭✭✭✭

    Is this in the Android Player? I had a problem with changing an app name and had to uninstall the app and restart the player before it would pick it up.

  • ChristianGraabkChristianGraabk DKMember ✭✭

    No, i run it straight on my phone.. I have tried cleaning the solution, uninstalling the app from my phone, deleting the bin and obj folders manually..
    And i have run out of ideas right now..

  • ChristianGraabkChristianGraabk DKMember ✭✭

    Okay, so i narrowed down the problem, it's on my phone the problem is.. Like the icon is cached in some way? Installed it on a friends phone, and i works fine...

  • seanydaseanyda GBMember ✭✭✭✭✭
    edited January 2016

    Go to Settings > Applications / Applications Manager > All Applications > Uninstall or Clear Cache and it should do the trick if its the phones problem.

    If not replace the files in the Resource folder which are 72x72, 72x72, 96x96, 144x144 and make sure all icons are replaced. It might render a different icon on your friends phone. Make sure they are .png images too.

  • ChristianGraabkChristianGraabk DKMember ✭✭

    I did all of the above.. And it hasn't helped one tiny bit. I even tried unistalling it from adb, to see if thet would help.

  • MichelangeloFrancoMichelangeloFranco ITUniversity ✭✭✭

    The solution of @SeanDavies.1435 it's correct.
    if you have some problem creating right icon size try with Android Asset Studio at this link: goo.gl/Dzs60V

    After you have added all icon in relatives folder, modify the Manifest and in the Application Icon choose your icon.

  • JimTyminskiJimTyminski USUniversity ✭✭

    @ChristianGraabk said:
    I did all of the above.. And it hasn't helped one tiny bit. I even tried unistalling it from adb, to see if thet would help.

    Did you find a solution? I am having SAME issue! Thanks!

  • NoumanUllahNoumanUllah USMember

    I am also facing the same issue, any luck @JimTyminski?

  • I faced same problem, and this thread didn't help. But this one on StackOverflow did the trick
    Simply, there are several versions of drowable folder (e.g. drawable, drawable-hdpi, drawable-xhdpi, etc) to represent different sizes of your icons
    All you need is to replace icon file in all those folders

  • BillLensonBillLenson USMember

    Jorge's solution worked for me. Thanks

  • Need to add: :)Icon = "@drawable/icon"
    If your code is =======================

    [Activity(Label = "My App", Theme = "@style/Theme.DesignDemo", MainLauncher = true)]

    The replace it by using below code.==============================================

    [Activity(Label = "My App", Theme = "@style/Theme.DesignDemo", MainLauncher = true, Icon = "@drawable/icon)]

    happy coding :smile:B)

  • Yusuf_AYusuf_A Member ✭✭

    After I replaced the images icon.png the app icon was not changed, I finally deleted the obj and bin folders and built the project.

Sign In or Register to comment.