Cant start ios simulator

My set up: -window7 with with visual studio xamarin extension
-Mac with latest el Capitan OSX on it with xamarin studio and the last version of Xcode

What I can do :- I can connect my window to my mac with the Mac agent without problem.
- I can open manually the simulator on my mac without any problem

What I can’t do : When I click on the button "show iOS simulator" I get this Error :

Failed to start iOS Simulator in the mac
Xamarin.Messaging.Exceptions.MessagingException: An error occured on client vs10644Utili while executing a post for topic xvs/idb/4.0.0.1717/show-app ---> System.TimeoutException: The operation has timed out.

I hope someone can help me! I’m on this for a while now.
Thank you

Logs :
Xamarin Information: 0 : [2016-01-11 10:31:59.8825] Xamarin - 4.0.0.1717-cycle6-xcode7.2+1390b70
Xamarin.VisualStudio.Shell.XamarinShellPackage Information: 0 : [2016-01-11 10:31:59.9100] Initial entitlements: iOS Trial
Xamarin.VisualStudio.Shell.XamarinShellPackage Information: 0 : [2016-01-11 10:31:59.9140] Running license sync for iOS
Xamarin.VisualStudio.Shell.XamarinShellPackage Information: 0 : [2016-01-11 10:31:59.9340] Initial entitlements: Android Trial
Xamarin.VisualStudio.Shell.XamarinShellPackage Information: 0 : [2016-01-11 10:31:59.9390] Running license sync for Android
Xamarin.VisualStudio.TastyPackage Information: 0 : [2016-01-11 10:32:03.4915] Hooked up SDB tracing adapter
Xamarin.VisualStudio.TastyPackage Information: 0 : [2016-01-11 10:32:03.4975] Initialization finished
Xamarin.VisualStudio.Android.XamarinAndroidPackage Warning: 0 : [2016-01-11 10:32:03.5010] Initializing Xamarin.VisualStudio.Android.XamarinAndroidPackage
Xamarin.VisualStudio.TastyPackage Information: 0 : [2016-01-11 10:32:04.3791] Hooked up SDB tracing adapter
Xamarin.VisualStudio.TastyPackage Information: 0 : [2016-01-11 10:32:04.3841] Initialization finished
Xamarin.VisualStudio.IOS.XamarinIOSPackage Warning: 0 : [2016-01-11 10:32:04.3876] Initializing Xamarin.VisualStudio.IOS.XamarinIOSPackage.
Xamarin.VisualStudio.IOS.XamarinIOSPackage Information: 0 : [2016-01-11 10:32:04.3946] MDAddinsHash: 83e91c86bddb2ffbe2451c8c21936dcf74982459

Xamarin.VisualStudio.Shell.XamarinShellPackage Information: 0 : [2016-01-11 10:32:06.6629] Updated license: Android Trial 2016-01-20 21:19:13
Xamarin.VisualStudio.IOS.Messaging.State.ServerStateContext Information: 0 : [2016-01-11 10:32:08.2441] MacServer State transition from DisconnectedState to SshConnectingState on Jean-Gabriels-iMac.local (10.1.4.94)
Xamarin.Messaging.VisualStudio.MessagingService Information: 0 : [2016-01-11 10:32:12.5551] Starting Broker 4.0.0.1717 in port 56778...
Xamarin.Messaging.Client.Ssh.SshCommandRunner Warning: 0 : [2016-01-11 10:32:12.5617] Failed to execute 'ls /usr/bin/mono': ExitStatus=1
Xamarin.Messaging.Client.Ssh.SshCommandRunner Warning: 0 : [2016-01-11 10:32:12.5797] ls: /usr/bin/mono: No such file or directory

Xamarin.VisualStudio.Shell.XamarinShellPackage Information: 0 : [2016-01-11 10:32:12.9232] Updated license: iOS Trial 2016-01-20 21:19:13
Xamarin.Messaging.VisualStudio.MessagingService Information: 0 : [2016-01-11 10:32:15.4330] SSH Connection established with the Mac 10.1.4.94:22:56778
Xamarin.VisualStudio.IOS.Messaging.State.ServerStateContext Information: 0 : [2016-01-11 10:32:15.6415] MacServer State transition from SshConnectingState to SshConnectedState on Jean-Gabriels-iMac.local (10.1.4.94)
Xamarin.VisualStudio.IOS.Messaging.State.ServerStateContext Information: 0 : [2016-01-11 10:32:15.6850] MacServer State transition from SshConnectedState to AgentsStartingState on Jean-Gabriels-iMac.local (10.1.4.94)
Xamarin.VisualStudio.IOS.Messaging.State.ServerStateContext Information: 0 : [2016-01-11 10:32:15.6965] Starting agents on Mac Jean-Gabriels-iMac.local (10.1.4.94)
Xamarin.VisualStudio.IOS.MacServer Information: 0 : [2016-01-11 10:32:15.7696] Activating the Mac...
Xamarin.Messaging.VisualStudio.MessagingService Information: 0 : [2016-01-11 10:32:20.3231] Starting Agent IDB 4.0.0.1717...
Xamarin.VisualStudio.IOS.Messaging.State.ServerStateContext Information: 0 : [2016-01-11 10:32:20.3346] MacServer State transition from AgentsStartingState to LimitedState on Jean-Gabriels-iMac.local (10.1.4.94)
Xamarin.VisualStudio.IOS.Messaging.State.ServerStateContext Information: 0 : [2016-01-11 10:32:20.3396] Connected to the Mac Jean-Gabriels-iMac.local (10.1.4.94) with Limited support.
Xamarin.Messaging.Client.Ssh.SshCommandRunner Warning: 0 : [2016-01-11 10:32:20.5777] Failed to execute 'ls /usr/bin/mono': ExitStatus=1
Xamarin.Messaging.Client.Ssh.SshCommandRunner Warning: 0 : [2016-01-11 10:32:20.5817] ls: /usr/bin/mono: No such file or directory

Xamarin.Messaging.VisualStudio.MessagingService Information: 0 : [2016-01-11 10:32:25.6648] Agent IDB 4.0.0.1717 is running
Xamarin.Messaging.VisualStudio.MessagingService Information: 0 : [2016-01-11 10:32:26.0029] Starting Agent Build 4.0.0.1717...
Xamarin.Messaging.Client.Ssh.SshCommandRunner Warning: 0 : [2016-01-11 10:32:26.2269] Failed to execute 'ls /usr/bin/mono': ExitStatus=1
Xamarin.Messaging.Client.Ssh.SshCommandRunner Warning: 0 : [2016-01-11 10:32:26.2309] ls: /usr/bin/mono: No such file or directory

Xamarin.Messaging.VisualStudio.MessagingService Information: 0 : [2016-01-11 10:32:28.1156] Agent Build 4.0.0.1717 is running
Xamarin.Messaging.VisualStudio.MessagingService Information: 0 : [2016-01-11 10:32:30.8065] Starting Agent Designer 4.0.0.1717...
Xamarin.Messaging.Client.Ssh.SshCommandRunner Warning: 0 : [2016-01-11 10:32:31.0470] Failed to execute 'ls /usr/bin/mono': ExitStatus=1
Xamarin.Messaging.Client.Ssh.SshCommandRunner Warning: 0 : [2016-01-11 10:32:31.0510] ls: /usr/bin/mono: No such file or directory

Xamarin.Messaging.VisualStudio.MessagingService Information: 0 : [2016-01-11 10:32:37.3383] Agent Designer 4.0.0.1717 is running
Xamarin.VisualStudio.IOS.Messaging.State.ServerStateContext Information: 0 : [2016-01-11 10:32:37.3423] MacServer State transition from LimitedState to ConnectedState on Jean-Gabriels-iMac.local (10.1.4.94)
Xamarin.VisualStudio.IOS.Messaging.State.ServerStateContext Information: 0 : [2016-01-11 10:32:37.3463] Connected to the Mac Jean-Gabriels-iMac.local (10.1.4.94) with Full support.
Xamarin.Messaging.Client.MessagingClient Error: 0 : [2016-01-11 10:32:57.4383] An error occured on client vs10644Utili while executing a post for topic xvs/idb/4.0.0.1717/show-app
System.TimeoutException: The operation has timed out.
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task)
at Xamarin.Messaging.Client.MessagingClient.d__22.MoveNext() Xamarin Error: 0 : [2016-01-11 10:32:57.4448] Failed to start iOS Simulator in the mac Xamarin.Messaging.Exceptions.MessagingException: An error occured on client vs10644Utili while executing a post for topic xvs/idb/4.0.0.1717/show-app ---> System.TimeoutException: The operation has timed out. at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task) at Xamarin.Messaging.Client.MessagingClient.<PostAsync>d__22.MoveNext()
--- End of inner exception stack trace ---
at Xamarin.Messaging.Client.MessagingClient.d__22.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at Xamarin.Messaging.Client.MessagingClient.<PostAsync>d__12.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Xamarin.Messaging.Client.MessagingClient.d__52.MoveNext() --- End of stack trace from previous location where exception was thrown --- at Xamarin.Messaging.Client.IMessagingClientExtensions.Execute[T](Func1 postFunction)
at Xamarin.Messaging.Client.IMessagingClientExtensions.Post[TRequest,TResponse](IMessagingClient client, TRequest message, Boolean retain, Int32 timeoutSecs)
at Xamarin.VisualStudio.IOS.IMessagingServiceExtensions.<>c__DisplayClass0.b__1() in C:\Users\builder\data\lanes\2599\1390b70a\source\XamarinVS\src\Core\VisualStudio.IOS\Extensions\IMessagingServiceExtensions.cs:line 38
Xamarin.Messaging.Client.MessagingClient Error: 0 : [2016-01-11 10:33:25.6844] An error occured on client vs10644Utili while executing a post for topic xvs/idb/4.0.0.1717/set-settings
System.TimeoutException: The operation has timed out.
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task)
at Xamarin.Messaging.Client.MessagingClient.d__22.MoveNext() Xamarin.VisualStudio.IOS.SettingsProvider Error: 0 : [2016-01-11 10:33:25.6939] Failed to set settings. System.TimeoutException: The operation has timed out. at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task) at Xamarin.Messaging.Client.MessagingClient.<PostAsync>d__22.MoveNext()
Xamarin.Messaging.Client.MessagingClient Error: 0 : [2016-01-11 10:36:23.6810] An error occured on client vs10644Utili while executing a post for topic xvs/idb/4.0.0.1717/show-app
System.TimeoutException: The operation has timed out.
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task)
at Xamarin.Messaging.Client.MessagingClient.d__22.MoveNext() Xamarin.Messaging.Client.MessagingClient Error: 0 : [2016-01-11 10:36:23.6875] Failed to start iOS Simulator in the mac Xamarin.Messaging.Exceptions.MessagingException: An error occured on client vs10644Utili while executing a post for topic xvs/idb/4.0.0.1717/show-app ---> System.TimeoutException: The operation has timed out. at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task) at Xamarin.Messaging.Client.MessagingClient.<PostAsync>d__22.MoveNext()
--- End of inner exception stack trace ---
at Xamarin.Messaging.Client.MessagingClient.d__22.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at Xamarin.Messaging.Client.MessagingClient.<PostAsync>d__12.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Xamarin.Messaging.Client.MessagingClient.d__52.MoveNext() --- End of stack trace from previous location where exception was thrown --- at Xamarin.Messaging.Client.IMessagingClientExtensions.Execute[T](Func1 postFunction)
at Xamarin.Messaging.Client.IMessagingClientExtensions.Post[TRequest,TResponse](IMessagingClient client, TRequest message, Boolean retain, Int32 timeoutSecs)
at Xamarin.VisualStudio.IOS.IMessagingServiceExtensions.<>c__DisplayClass0.b__1() in C:\Users\builder\data\lanes\2599\1390b70a\source\XamarinVS\src\Core\VisualStudio.IOS\Extensions\IMessagingServiceExtensions.cs:line 38

Posts

  • BenFidgeBenFidge USMember

    Hi, Ive been getting the same problem and hitting my head against the wall. When I plugged my ipad in, it all started working! Weird.

    See:

    http://forums.xamarin.com/discussion/57044/ios-simulator-do-not-start-in-the-mac

    I've got the device registered under my development account on Apple Developer site so i dont know if its anything ot do with this?

    Hope this helps.

    Ben

  • ChrisColeTechChrisColeTech USMember ✭✭✭

    You may have to disconnect -> reconnect a few times.

    Just another bug in Xamarin (what else is new, right?)

  • ZontagZontag BRMember ✭✭

    same here.. Is really hard work with all these bugs.

  • ZontagZontag BRMember ✭✭

    Solved problems here by removing and adding again each simulator device.

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University, Xamarin Moderator Xamurai

    Hi all,

    I just filed a bug report about this:
    https://bugzilla.xamarin.com/show_bug.cgi?id=38695

    But the only info I have is what is noted here. Please feel free to update the bug report with any information you feel is relevant. Thanks!

  • LyndonHugheyLyndonHughey USUniversity ✭✭✭

    @Zontag said:
    Solved problems here by removing and adding again each simulator device.

    I also resolved it by repeatedly disconnecting and reconnecting to the build server a few times.

  • ChrisHanChrisHan USMember ✭✭

    Same problem here. Reconnect twice or thrice fixed it.(But only temporary) I hope they fix it soon! It is depressing.....

  • WinSomeLoseSomeWinSomeLoseSome USMember ✭✭

    Just hit this. None of the usual hacks is fixing it. Very depressing. Complete waste of time. Just built and deployed fine 2 hours ago and all of the sudden it wouldn't build the appstore build. Runs in simulator fine on remote mac using various phones and iOS versions, but won't build for AppStore. My fix is to copy the source code over to the mac and build from there, not sure if that is going to work, but it is the only trick I have left aftre disconnecting the remote mac and reconnecting multiple times, rebooting both win7 and mac, etc. Also updated the Xamarin Nuget packages as the logs indicated a version mismatch. Didn't help either.

  • JohnHairJohnHair GBMember ✭✭✭✭

    @PatrickMagee.5014 this thread is from a year ago and is related to the iOS Simulator and not AppStore builds. Much has changed so I would suggest posting a new thread with the issue you are having, for example what error you are getting when trying to build for AppStore.

  • AshleyGazichAshleyGazich USXamarin Team Xamurai

    @PatrickMagee.5014
    This thread is quite old and may not be relevant for the issue you are having. For troubleshooting a new scenario, I would recommend creating a new forum discussion or question. Thanks!

Sign In or Register to comment.