XamlSamples.iOS `App' does not exist in the namespace `XamlSamples'.

/xamarin-forms-samples/XAMLSamples/XamlSamples/XamlSamples.iOS/AppDelegate.cs(37,37): Error CS0234: The type or namespace name `App' does not exist in the namespace `XamlSamples'. Are you missing an assembly reference? (CS0234) (XamlSamples.iOS)

Brand new to Xamarin forums, simply wanted to download the samples as I've followed most of the XAML tutorials and made my own.
I git cloned from https://github.com/xamarin/xamarin-forms-samples/tree/master/XAMLSamples
Then I opened and tried to build iOS Xamarin then encountered the error.

Now, I'm running on a mac with Xamarin studio.
I looked around for a fix, everything that was suggested doesn't work. (Deleting packages and updating them)


  • ThomasBurkhartThomasBurkhart DEMember ✭✭✭✭

    I think I ran into the same problem. My guess is there is a bug in this example. Others work fine. Have you read the preview of Charles Petzold's Forms book?
    You can copy and paste the samples from there.

  • BuildCalcBuildCalc USMember ✭✭✭

    When this has happened to me, it seems like the there was a problem with the solution (rather then the project). If you're using Xamarin Studio, you can try the following:

    • Right click on the iOS project.
    • Select "Delete". A dialog box with "Do you really want to remove project your_project_name.iOS from your_solution_name?
    • Click [Remove].
    • Now, right click on your solution and select "Add existing project ...". A file open dialog will appear.
    • Navigate in the file-open dialog until you find the your_project_name.iOS.csproj file. Select it and click [Open]

    This should reset it in your solution.

  • FalkFalk USMember ✭✭

    Same here.
    Solves this your(Abakiz) problem explained by buildcalc?

Sign In or Register to comment.