Mac App rejected due to MapKit not being linked

My app was rejected from the Mac App Store for the following reason:
2.3 - Apps that do not perform as advertised by the developer will be rejected

The app still has the MapKit entitlement without linking against the MapKit framework.

My application targets the 64 bit architecture, links to the Native MapKit, associates the CFBundleIdentifier in Info.plist to the one created with Apple with Maps permissions. I am using the latest Stable releases of Xamarin.

Any thoughts on why this would happen?

Posts

  • ChrisHamonsChrisHamons USXamarin Team Xamurai

    So, there isn't much we can do without more information.

    • Does the applications MapKit related functionality work locally for you? With the associated sandboxing enabled?
    • A full build log would be useful. So would the relevant snippet from your Info.plist

    Since it is near Christmas, you may receive limited response on the forums for the next week or two. A number of people travel, or are otherwise not checking the forums.

  • MatthewHannonMatthewHannon USMember
    edited December 2015

    (removed)

  • Chris,

    Thanks for the response.

    -MapKit works fine locally and on a guest account (pic attached)
    -Build log and Info.plist is attached as PDF

    Let me know what else you need.

  • All,

    Any insights on how to rectify?

    Thanks

  • ChrisHamonsChrisHamons USXamarin Team Xamurai

    The fact that the application works for you means we're obviously pulling in MapKit successfully.

    Maybe add "-framework MapKit" to you additional mmp arguments, rebuild, and resubmit it? I don't see how that would change behavior, but maybe it'd make Apple happy?

  • RogisterAlainRogisterAlain BEBeta ✭✭✭

    Hi Chris,

    I posted my application Friday and it is rejected for the following reason:

    Your app contains the Maps entity, but it does not link against the MapKit framework.

    Next Steps

    If you would like to include Maps, please link against the MapKit framework and submit an updated binary.

    resources

    For information on Maps, please review the Location and Maps Programming Guide.

    I do not understand why ! I have posted 10 versions for 2 years and I have never had this problem. They first told me to add com.apple.developer.maps because I was using Maps and now it rejects with the above error.

    I rested this Saturday by adding in the compilation arguments:

    -framework MapKit

    But I still have today a refusal with the same problem.

    I recall that I compiled my application in AOT: full -linkallplatfom, I do not know if that can be the problem.

    What should I do ?

    Thank you

    Alain

  • ChrisHamonsChrisHamons USXamarin Team Xamurai

    I've responded in the bug you've filed:

    https://bugzilla.xamarin.com/show_bug.cgi?id=59722

    requesting more information. You did not mention in the bug (but here) that you tried forcing the framework link.

    Did you use link_flags to do that? What does otool -L on your binary output?

  • RogisterAlainRogisterAlain BEBeta ✭✭✭

    Hello,

    APPLE has enabled my application with this setting. --link_flags="-framework MapKit"

    So for those who use Maps in their application and use the Sandboxing, do not forget to put this parameter in the compilation options otherwise you will have a rejection by APPLE.

    Chris, is not it possible to add this automatically when compiling if we activated Maps in the info.plist ???

    Thank you

    Alain

  • ChrisHamonsChrisHamons USXamarin Team Xamurai

    So I could see needing "-framework MapKit" if you are somehow using a MapView and not referencing a single MapKit API in your C#.

    Beyond that, I'm struggling to understand how you are in this position without a sample or more information.

  • RogisterAlainRogisterAlain BEBeta ✭✭✭

    Chris,

    it is quite simple. From the beginning, I use MapKit in my application with the Sandbox.

    I don't know why but in the Entetilment file, I didn't put com.apple.developer.maps malgated that the activation of Maps was done. (Maybe I deleted it, I don't know).

    So for 1.5 years, I posted my app at APPLE like that and I never had a refusal.

    Here they first told me that I had to specify com.apple.developer.maps, which I did and then I had the problem you know. And so to solve, that, I did what you told me by putting in the compilation options the line requested.

    The question I asked myself is why do not systematically put this in the compilation options when we acitve Maps so that it is not rejected by APPLE and that other people have this problem because they do not know like me that they must put this compilation option for it not be rejected. This is a suggestion ...

    Alain

  • RogisterAlainRogisterAlain BEBeta ✭✭✭

    Hi,

    I'm disappointed that no one answers my question for this problem. I am currently blocked and I don't know how to post my application at APPLE for the same refusal. It always tells me that the MapKit framework is not present.

    But when I run oTool - L, I see the MapKit framework as mentioned in the bug. I don't understand what I can do.

    I have been working with Xamarin products for over 4 years and I have never had this type of problem and support (or others) always do a maximum to help.

    Can someone help me ?

    Thank you

    Alain

  • TimothyRisiTimothyRisi USXamarin Team Xamurai

    Is your app rejected when you try to upload it to iTunes Connect or during app review after trying to submit it to the app store?

  • ChrisHamonsChrisHamons USXamarin Team Xamurai

    As noted here - https://bugzilla.xamarin.com/show_bug.cgi?id=59722#c19

    Hey Alain - engineering isn't always going to be able to respond right away on Bugzilla items. For quick responses with engineers dedicated to one-on-one support, I'd suggest checking out the "Create an incident" link here: https://www.xamarin.com/support

    It is not that people are unwilling to help, you are not either asking in the right places, not giving sufficient information, or not responding when we ask.

    Please consider posting your exact response from Apple, what you have attempted to do, and someone can try to help.

  • RogisterAlainRogisterAlain BEBeta ✭✭✭

    As Chris suggested, I contacted Xamarin Support.

    For the moment, I posted my application because it was urgent without Maps. I removed in my application all that concerned Maps. There, this has been validated by APPLE.

    The refusal happens during the app review.

    Now that the application has passed, I will be releasing a new version this week by reentering Maps. I will first try with Xamarin.Mac 4.0 and if that does not happen, I would try with version 3.8 because with this version, it was spent 2 months ago.

  • RogisterAlainRogisterAlain BEBeta ✭✭✭

    FYI, I rested the application at APPLE integrating Maps (the same application that 2 weeks ago) and there, the application is validated by APPLE.

    I really do not understand (Same version Xamarin.MAC 4.0.0.214) and same compile option

    I informed the support.

    Alain

Sign In or Register to comment.