Google Play Services Binding Version vs Actual Version

The bindings for the Google Play Services lib seem to have a version number such as 25.0, 26.0, 27.0 ...

whereas the actual version number of the Google Play Services library downloaded to the device is totally different i.e. 7.5, 8.4 ...

How do these two versions numbers relate to each other, I can't find anything out there which tells me?

Posts

  • MarkRileyMarkRiley GBMember ✭✭

    To answer my own question: the version number in the components store corresponds to the GPS 'Revision'. This is the same number you see in the Android SDK Manager.

    To match the 'Revision Number' to the 'Version Number', you can look in the downloaded component, under:

    'google-play-services\libproject\google-play-services_lib\res\values'
    

    This contains a 'version.xml' file which contains the actual version number.

  • bansheebanshee USMember

    You can also unzip the nupkg file (you can download it from nuget.org) and look at the nuspec file. For example, xamarin.firebase.messaging.42.1001.0.nupkg contains this Xamarin.Firebase.Messaging.nuspec file:

    <?xml version="1.0" encoding="utf-8"?> <package xmlns="http://schemas.microsoft.com/packaging/2013/05/nuspec.xsd"> <metadata> <id>Xamarin.Firebase.Messaging</id> <version>42.1001.0</version> <title>Xamarin Firebase - Messaging</title> <authors>Xamarin Inc.</authors> <owners>Xamarin Inc.</owners> <requireLicenseAcceptance>true</requireLicenseAcceptance> <licenseUrl>https://github.com/xamarin/GooglePlayServicesComponents/blob/master/LICENSE.md</licenseUrl> <projectUrl>https://github.com/xamarin/GooglePlayServicesComponents/</projectUrl> <iconUrl>https://raw.githubusercontent.com/xamarin/GooglePlayServicesComponents/master/icons/firebase-messaging_128x128.png</iconUrl> <description>Xamarin.Android Bindings for Firebase - Messaging 10.0.1</description> <summary>Xamarin.Android Bindings for Firebase - Messaging 10.0.1</summary> <copyright>Copyright © Microsoft Corporation</copyright> <dependencies> <group targetFramework="MonoAndroid7.0"> <dependency id="Xamarin.GooglePlayServices.Basement" version="[42.1001.0]" /> <dependency id="Xamarin.Firebase.Iid" version="[42.1001.0]" /> <dependency id="Xamarin.Firebase.Common" version="[42.1001.0]" /> </group> </dependencies> </metadata> </package>

Sign In or Register to comment.