Inspector not working, cannot reinstall

I downloaded the Inspector the other day, and used it successfully a few times, but now it has ceased working. I do not have the Inspect button in Xamarin Studio anymore and I cannot seem to open the application directly (it's not listed on my machine).

I tried reinstalling the tool a few times, but the installer always fails. I also tried removing the Add-In from Xamarin Studio before reinstalling, but again, no luck.

Here's the log from the installer

Nov 24 15:42:04 tech-ntaylormbp-2 Installer[1044]: @(#)PROGRAM:Install  PROJECT:Install-1000
Nov 24 15:42:04 tech-ntaylormbp-2 Installer[1044]: @(#)PROGRAM:Installer  PROJECT:Installer-853
Nov 24 15:42:04 tech-ntaylormbp-2 Installer[1044]: Hardware: MacBookPro11,1 @ 2.80 GHz (x 4), 16384 MB RAM
Nov 24 15:42:04 tech-ntaylormbp-2 Installer[1044]: Running OS Build: Mac OS X 10.11.1 (15B42)
Nov 24 15:42:04 tech-ntaylormbp-2 Installer[1044]: Xamarin Inspector 0.3.2.3  Installation Log
Nov 24 15:42:04 tech-ntaylormbp-2 Installer[1044]: Opened from: /Users/ntaylor/Downloads/XamarinInspector.pkg
Nov 24 15:42:06 tech-ntaylormbp-2 Installer[1044]: InstallerStatusNotifications plugin loaded
Nov 24 15:42:45 tech-ntaylormbp-2 Installer[1044]: ================================================================================
Nov 24 15:42:45 tech-ntaylormbp-2 Installer[1044]: User picked Standard Install
Nov 24 15:42:45 tech-ntaylormbp-2 Installer[1044]: Choices selected for installation:
Nov 24 15:42:45 tech-ntaylormbp-2 Installer[1044]:  Upgrade: "Xamarin Inspector 0.3.2.3"
Nov 24 15:42:45 tech-ntaylormbp-2 Installer[1044]:  Upgrade: "(null)"
Nov 24 15:42:45 tech-ntaylormbp-2 Installer[1044]: ================================================================================
Nov 24 15:42:49 tech-ntaylormbp-2 Installer[1044]: Configuring volume "Macintosh HD"
Nov 24 15:42:49 tech-ntaylormbp-2 Installer[1044]: Free space on "Macintosh HD": 100.12 GB (100118802432 bytes).
Nov 24 15:42:49 tech-ntaylormbp-2 Installer[1044]: Create temporary directory "/var/folders/w8/kl_7xslj4cg0ytkwny_g48q1j2_d8z/T//Install.1044AbIJoL"
Nov 24 15:42:49 tech-ntaylormbp-2 Installer[1044]: IFPKInstallElement (1 packages)
Nov 24 15:42:49 tech-ntaylormbp-2 Installer[1044]: PackageKit: Enqueuing install with framework-specified quality of service (utility)
Nov 24 15:42:49 tech-ntaylormbp-2 installd[496]: PackageKit: ----- Begin install -----
Nov 24 15:42:50 tech-ntaylormbp-2 installd[496]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “XamarinInspector.pkg”." UserInfo={NSFilePath=./postinstall, NSURL=file://localhost/Users/ntaylor/Downloads/XamarinInspector.pkg#Framework.pkg, PKInstallPackageIdentifier=com.xamarin.Inspector, NSLocalizedDescription=An error occurred while running scripts from the package “XamarinInspector.pkg”.} {
        NSFilePath = "./postinstall";
        NSLocalizedDescription = "An error occurred while running scripts from the package \U201cXamarinInspector.pkg\U201d.";
        NSURL = "file://localhost/Users/ntaylor/Downloads/XamarinInspector.pkg#Framework.pkg";
        PKInstallPackageIdentifier = "com.xamarin.Inspector";
    }
Nov 24 15:42:51 tech-ntaylormbp-2 Installer[1044]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.
Nov 24 15:42:51 tech-ntaylormbp-2 Installer[1044]: IFDInstallController 52E6FAE0 state = 8
Nov 24 15:42:51 tech-ntaylormbp-2 Installer[1044]: Displaying 'Install Failed' UI.
Nov 24 15:42:51 tech-ntaylormbp-2 Installer[1044]: 'Install Failed' UI displayed message:'The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.'.

Best Answer

Answers

This discussion has been closed.