iOS 9 not showing splash - launch screen

AzucenaFAzucenaF MXMember ✭✭

Hi! I have added a LaunchScreen xib file to my Forms project. The first time after adding launch screen it worked ok, but then I modified the screen and now only shows a black screen.

I have tried to delete UILaunchStoryboardName key-value on Info.plist, clean, run, add launch screen, clean and run again and it does not work. I'm using a real iPhone 6 iOS 9 device for testing

Has anyone had the same issue?


  • AlanSpiresAlanSpires USBeta ✭✭

    In a Forms project for iOS all you have to do is add the Launch Images to the plist file to get a Splash screen. No additional xib's or code is needed.

  • AzucenaFAzucenaF MXMember ✭✭

    @AlanSpires I actually have added the images that way and it does not work. It works on iOS 7 and 8, but not on ios9

  • AlanSpiresAlanSpires USBeta ✭✭

    @AzucenaF The apps I've built all run on 7,8,9 by just adding the Launch images. I'm not exactly sure whats happening in your case.

  • JulienRosenJulienRosen CAMember ✭✭✭✭

    Can you guys explain what "adding the launch images" entails.

    Are you just following the naming convention ([email protected]) and adding them to Resources folder, then manually editting the Info.plist file to include them?

  • AzucenaFAzucenaF MXMember ✭✭

    @JulienRosen You have to add the launch images following the name convention to the Resources folder and then drag and drop them to the info.plist or manually editing the file

  • JulienRosenJulienRosen CAMember ✭✭✭✭

    @AzucenaF are you using XS or VS? Mac or Windows?

  • AzucenaFAzucenaF MXMember ✭✭

    @JulienRosen Xamarin Studio - Mac

  • JassimRahmaJassimRahma USMember ✭✭✭✭

    I have the same problem.
    I have added all Launch images to the Asset..xcassets
    info.plist ->Deployment Info->Main Interface=launchScreen
    info.plist ->iPhone Launch Images is blank

  • AdamMeaneyAdamMeaney USMember ✭✭✭✭✭

    I know when using it from Visual Studio for WIndows, it loses our icon most of the time. Both launch images and app icons don't appear.

    They are there in release builds though.

    Due to this, we migrated to the LaunchStoryboard option, which always worked and is the recommended way now anyway.

Sign In or Register to comment.