Visual Studio hangs loading solution

GerryHighGerryHigh USBeta ✭✭✭

FYI - in trying to load my solution in Visual Studio it was hanging indefinitely. I'm running the latest 4.x releases. My solution contains a PCL, shared project, and iOS and Android projects.

Thanks to @KyleMasters deleting the hidden .vs folder forced Visual Studio to rebuild and now it seems like everything is working.

  • Gerry
Tagged:

Posts

  • JulianPasqueJulianPasque USMember ✭✭✭

    This solution saved me alot of time!
    Thanks @GerryHigh

  • GerryHighGerryHigh USBeta ✭✭✭

    FWIW It happened to me again on the same solution but just deleted the .vs folder again to fix. Hopefully this gets fixed before too long.

  • FrancoisMFrancoisM FRUniversity ✭✭
    edited November 2015

    +1 I don't know which vs folder you refer to. In my case I deleted the .suo hidden file.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited April 2017

    The issues from this forum thread are now being tracked by the following two bugs:


    I will now close this thread to consolidate any further discussion onto the corresponding bug reports. Feel free to post any further findings about improved or more detailed workarounds on the appropriate bug report to make them visible to other users.

    If anyone hits a hang after upgrading to Xamarin 4 where the call stack of the Main Thread (collected as described under "How to diagnose" on Bug 36185, Comment 1) does not include "GetAdditionalResourcesFromAssemblies", please do file a new bug report against Xamarin 4 "Cycle 6 Stable" and attach your Main Thread call stack.

    See also the Xamarin 4 Release Announcement for information about other known issues in the latest release, including a link to the full "Xamarin 4 Bug List," which now includes both of the bug reports mentioned in this thread.

    (As always, I'm also happy to reopen the thread upon request within the next month or two. Just send a quick email to [email protected] with a link to this thread. For follow-up after the next couple of months, if the remaining related open bug reports or forum threads do not cover the desired scenario, please follow the recommendations to create a new bug report, forum thread, or Stack Overflow question. Thanks!)

This discussion has been closed.