Crashes not being reported

I have some devices that work in a "protected" wifi lan without the possibility to connect to internet.

I have enabled on my firewall the address "xaapi.xamarin.com" but seems that the insights calls don't use the proxy: the crashes not being reported. Is it possible?

Which instruction should I insert to permit to Insight to send his reports using my proxy?

Best Answer

Answers

  • BarryDunneBarryDunne IEUniversity

    I can confirm that Insights does not work when using wifi with a proxy. It gives the following warning:
    W/Xamarin.Insights( 4276): Warning: Could not post to webapi: Network state is disabled. Can not ping webapi

    It would seem that the http communications are not using the network proxy settings, eg:

    string proxyHost = Java.Lang.JavaSystem.GetProperty("http.proxyHost");
    string proxyPort = Java.Lang.JavaSystem.GetProperty("http.proxyPort");
    HttpClient httpClient = new HttpClient(new HttpClientHandler { UseProxy = true, Proxy = new WebProxy($"{proxyHost}:{proxyPort}", false, new string[] { }) });
    
  • AlessandroCaliaroAlessandroCaliaro ITMember ✭✭✭✭✭

    @BarryDunne I hope Xamarin will work to solve this situation. I have the same problem with a big client...

  • AlessandroCaliaroAlessandroCaliaro ITMember ✭✭✭✭✭

    @ChristopherDeutsch I have this in Visual Studio console

    [Xamarin.Insights] Warning: Could not post to webapi: Network state is disabled. Can not ping webapi

    What is?

  • ChristopherDeutschChristopherDeutsch USXamarin Team, Insider Xamurai

    @AlessandroCaliaro said:
    @ChristopherDeutsch I have this in Visual Studio console

    [Xamarin.Insights] Warning: Could not post to webapi: Network state is disabled. Can not ping webapi

    What is?

    It means Insights can't talk back to the Xamarin servers.

    In the past, this is usually due to a firewall config or SSL certificate pinning problem

    Make sure your device can reach
    https://xaapi.xamarin.com/api/ping

Sign In or Register to comment.