Visual Studio gets disconnected from mac

mafmaf USMember ✭✭

After the recent upgrade which adds the SSH-based integration, I often see it get disconnected after a few hours.

VS xamarin log:
Disconnected from Mac 192.168.11.5 (192.168.11.5)
Couldn't connect to 192.168.11.5. Please try again.
Disconnected from Mac 192.168.11.5 (192.168.11.5

I then try clicking the "debug" button as a means of re-triggering the Xamarin mac agent setup wizard, and after re-entering my credentials I get "couldn't connect". (But attempting to log in with SSH via Putty.exe works just fine)

Once I completely close and restart Visual Studio and re-open the solution, I'm able to connect for a few more hours.

Posts

  • CodyBCodyB USXamarin Team Xamurai

    @maf

    Hey! Are you able to describe a few more details of this issue? Are you actively using the connection during this time, or is the computer asleep/working on other items?

    Also, can you provide the logs from:

    • Mac – ~/Library/Logs/Xamarin-[MAJOR.MINOR]
    • Windows – %LOCALAPPDATA%\Xamarin\Logs

    Thanks!

  • Gabor.SuranyiGabor.Suranyi USMember ✭✭

    Having the same issue here. Both Mac and Visual Studio uses the same channel same release.

    Logs:

    Ide log, related part:

    Xamarin.VisualStudio.IOS.Messaging.State.ServerStateContext Information: 0 : [2015-11-19 16:59:49.2790] MacServer State transition from DisconnectedState to SshConnectingState on IFMAC01.local (192.168.17.48)
    Xamarin.Messaging.VisualStudio.MessagingService Information: 0 : [2015-11-19 16:59:54.4859] Starting Broker 4.0.0.1689 in port 58857...
    System.Net.Mqtt.Client.Client Error: 0 : [2015-11-19 17:00:00.2530] System.Net.Mqtt.Client.ClientException: The client vs8004Kiral has been disconnected while trying to perform the connection
       at System.Net.Mqtt.Client.Client.<ConnectAsync>d__3.MoveNext()
    Xamarin.VisualStudio.IOS.Messaging.State.ServerStateContext Information: 0 : [2015-11-19 17:00:00.4660] MacServer State transition from SshConnectingState to DisconnectedState on IFMAC01.local (192.168.17.48)
    Xamarin.VisualStudio.IOS.Messaging.State.ServerStateContext Error: 0 : [2015-11-19 17:00:00.6760] An error occurred on the underlying client while executing an operation. Details: The client vs8004Kiral has been disconnected while trying to perform the connection
    Xamarin.VisualStudio.IOS.Messaging.State.DisconnectedState Information: 0 : [2015-11-19 17:00:00.8810] Disconnected from Mac IFMAC01.local (192.168.17.48)
    Xamarin.VisualStudio.IOS.Messaging.State.ServerStateContext Error: 0 : [2015-11-19 17:00:01.0510] Couldn't connect to IFMAC01.local. Please try again.
    

    No other logs contain related information. Our Mac had no logs of this event.

  • CodyBCodyB USXamarin Team Xamurai
    edited November 2015

    Hey everyone

    I have created the following bug report: https://bugzilla.xamarin.com/show_bug.cgi?id=36063

    Please feel free to subscribe to that report to be notified of updates.

    Thanks!

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited April 2017

    Many thanks for the report and the log files!

    The corresponding public report Bug 36063 now appears in the Xamarin 4 "Cycle 6" Bug List for tracking.


    I will now close this thread to consolidate any further discussion onto that bug report. Feel free to post any findings about new workarounds there to make them visible to other users.

    (See also the Xamarin 4 Release Announcement for information about other known issues in the latest release.)

    (As always, I'm also happy to reopen the thread upon request within the next month or two. Just send a quick email to [email protected] with a link to this thread. For follow-up after the next couple of months, if the remaining related open bug reports or forum threads do not cover the desired scenario, please follow the recommendations to create a new bug report, forum thread, or Stack Overflow question. Thanks!)

This discussion has been closed.