Inspector Early Preview Released!

SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai
edited December 2015 in Workbooks & Inspector

We are very happy to announce the availability of a preview of the Xamarin Inspector, a new tool to help you explore the inner workings of your apps. You can inspect the visual tree of your running app, and execute C# code live in a REPL, without even having to pause.

You may have seen this tool demoed during this year's Build conference (skip to the 33 minute mark). We spent the summer making the integration so easy that you can start inspecting your app with the touch of a single button.

We provide a Xamarin Studio add-in, a Visual Studio extension, and rich clients for Mac and Windows (all bundled together in our installers). You can inspect iOS, Android, Mac, and WPF apps. Please see the documentation for details and downloads. The latest Xamarin RC is required.

We are providing this preview to get our work into your hands as quickly as possible. But of course, it's an early preview, and we are just getting started. We'd love to hear your feedback about this tool, and any ideas you have to make it work better for you and your app. If you find any bugs (shock!), please file in our bugzilla.




  • JamieHoustonJamieHouston USMember ✭✭

    Are there any requirements around the type of project that this is available for? I'm trying to use it for an iOS project (using Xamarin.Forms) and I don't see the "Inspect Button" on the debug toolbar. I just updated to the alpha version of Xamarin Studio on OSX.

    Version 5.10 (build 860)
    Installation UUID: bb25170e-a3fd-489d-bae8-00d8dc76f385

    I haven't tried the same solution in Visual Studio as I use that for my primary dev environment and I was having issues with the RC necessary to use Inspector. But I'm really excited to check it out.

  • MigueldeIcazaMigueldeIcaza USXamarin Team Xamurai

    Did you install the Inspector after you installed Xamarin Studio? This is a requirement.

  • RyanDavisRyanDavis AUInsider, University ✭✭

    Great stuff, very cool!

    Still having a play around with it, but I noticed that paired double quotes change into '66' / '99's, so you can't enter a string literal:

    This is using OSX, I haven't tried VS.

  • Using alpha channel. I installed inspector on Mac and ran a C# ios app. When I entered an expression in the inspector, I got a spinning icon and after some time it timed out.

    On windows, Visual Studio, I ran android app, and I don't see the inspector icon (also it is not present in the Tools menu).

    On windows, Xamarin Studio, I ran same android app, the inspector icon is visible but grayed out.

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai
    edited November 2015

    @RyanDavis somebody else reported this as well: . The reporter noted that he fixed it through Edit > Substitutions > Smart Quotes. I'll be looking at fixing this for the next preview release (we intend to do them frequently, similar to the Profiler).

    EDIT: From my investigation, this should only be a problem the first time the Inspector client runs. Every time after that, it should automatically disable smart quotes (and similar features).

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    @JamieHouston go to Xamarin Studio > Add-in Manager... > Installed > IDE extensions and look for "Xamarin Inspector" to make sure it's properly installed. Also make sure you are debugging your app in the simulator, and not on a device.

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    @BabuSrinivasan.4944 thanks for testing it out, sorry you're running into troubles.

    For your Android project, make sure you're targeting Android 4.0.3 (API level 14) or greater, that you have "Use shared Mono runtime" and "Fast assembly deployment" checked, and also you need to be running in XAP or the Visual Studio Android Player.

    Also good to check that you're running in debug mode, not release.

    For the iOS project, I'd love to see some logs. ~/Library/Logs/XamarinStudio-5.0/Ide.log and ~/Library/Logs/Xamarin/Inspector/Xamarin Inspector {date}.log. Thanks!

  • JamieHoustonJamieHouston USMember ✭✭

    @SandyArmstrong I wasn't using an emulator... I completely missed that requirement. Got it working now. Awesome!

  • JamieHoustonJamieHouston USMember ✭✭

    I found out that you need to have iOS projects set to Not Link in the Build Options linker behavior. In case other people get the error "Can not start inspector: Method 'UIDevice.get_Name' not found." just turn off linking. The thread from bugzilla is here:

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    In the next release we'll check the linker setting before enabling inspection support. In my testing I got a different error than you, @JamieHouston, but it still crashed on startup.

  • RyanDavisRyanDavis AUInsider, University ✭✭

    @SandyArmstrong, aha - great! Thanks.

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    @RyanDavis It looks like we are disabling smart quotes (and similar features), but the setting only starts working on the second run of the Inspector client app. We'll get that fixed for the next release, too.

  • JovanPaskota.2946JovanPaskota.2946 SEUniversity

    I'm running XamarinStudio on OSX Version 5.10 (build 860). Installed inspector after XS and still don't see the button for startin inspector. Any other tip on how to start it?


  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    @JovanPaskota.2946 make sure you restart Xamarin Studio after installing the Inspector, that you're running your app in debug mode, and that it meets the requirements specified here: .

    Let me know if you're still having troubles after that.

  • infoMantisinfoMantis DEUniversity ✭✭

    So, since this doesn't work with the normal Android Emulator... Will there be an Android TV image for XAP?

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    @BorisSpinner good question; unfortunately I don't know the answer.

    I imagine we'll eventually get Google emulator support working. I didn't put much time into trying for the preview release; XAP and the VS Emulator were higher priority.

Sign In or Register to comment.