Storyboard not showing Ui elements

skm.7673skm.7673 USMember
edited October 2015 in Cross Platform with Xamarin

Hi Team,

I have a weird problem with my Storyboards. I have designed all my UI for iPhone(min 5s). I have used constraints to perfectly fit for the various screen sizes.

When I select Generic from the drop down at the top, I don't see any UI elements on the View. Thus I can't edit the storyboard for other screen sizes. The UI is visible only if i select iPhones (5s 4s 6 6plus). But when I choose generic I cant see my UI element on the view.

How can I make them available for Generic device size.

And, it is the same behaviour when I open in Xcode. I don't see the element on the UI.

Thanks

Posts

  • GWilkoGWilko USMember

    I have exactly the same problem as this. It's extremely irritating and nobody seems to have an answer!

  • rmaciasrmacias USBeta, University ✭✭✭✭✭

    You added views to a specific size class (such as iPhone Portrait), then those views will only be visible on those size classes. What you want to do is create your UI using th Any Width and Any Height (Generic) Size class. Add your constraints as usual. Then you would change your size classes view and verify your constraints work on all device sizes. Then, if needed, you can add other views on specific size classes.

    https://developer.xamarin.com/guides/ios/platform_features/introduction_to_unified_storyboards/

  • In Storyboard, all I did was click to switch to landscape then back to portrait and the controls started to appear again

Sign In or Register to comment.