Preview Release: Xamarin Studio 6.0 with Roslyn Support

1246

Posts

  • NealCulinerNealCuliner USBeta ✭✭✭

    How do I turn off the italicizing local variables in the ALPHA channel release I'm using now?

  • NealCulinerNealCuliner USBeta ✭✭✭

    This has been an issue forever, I'd love to see it fixed in XS 6 going forward. Set the drop downs in various project settings to the "Active Config" instead of "Debug". For example if I have the solution at the top left of XS set to RELEASE and I go into the project settings I would expect that RELEASE is the set config in the drop downs in the related areas that have build config drop downs.

  • mattwardmattward GBMember Xamurai

    @NealCuliner - The italic style is defined in the syntax highlighting (Preferences - Text Editor - Syntax Highlighting). You should be able to disable this by creating a new syntax style and removing the italic style from User Field Declaration and User Field Usage.

  • NinaKharchenkoNinaKharchenko RUMember
    edited March 2016

    After upgrading to Xamarin Studio 6.0 Build Output (Sport.Android sample project) contains only:

    Building: Sport.Android (Debug)

    ---------------------- Done ----------------------

    Build failed.
    Build: 1 error, 0 warnings

    Errors tab contains:

    Build failed. See the build log for details.

    Ide log contains following:

    WARNING [2016-03-01 12:42:15Z]: Unregistered TargetFramework '.NETFramework,Version=v4.5.1' is being requested from SystemAssemblyService, returning empty TargetFramework
    ERROR [2016-03-01 13:42:20Z]: Build failed.
    System.InvalidOperationException: No compatible framework found for assembly 'C:\Program Files (x86)\Xamarin Studio\bin\MSBuild\dotnet.14.0\MonoDevelop.Projects.Formats.MSBuild.exe' (required framework: .NETFramework,Version=v4.5.1)
    в MonoDevelop.Core.Assemblies.TargetRuntime.ExecuteAssembly(ProcessStartInfo pinfo, TargetFramework fx) в C:\Users\builder\data\lanes\88\a354b2cb\source\monodevelop\main\src\core\MonoDevelop.Core\MonoDevelop.Core.Assemblies\TargetRuntime.cs:строка 246
    в MonoDevelop.Projects.MSBuild.MSBuildProjectService.<>c__DisplayClass81_1.b__0() в C:\Users\builder\data\lanes\88\a354b2cb\source\monodevelop\main\src\core\MonoDevelop.Core\MonoDevelop.Projects.MSBuild\MSBuildProjectService.cs:строка 990
    в System.Threading.Tasks.Task`1.InnerInvoke()
    в System.Threading.Tasks.Task.Execute()

    Rollback to XS 5.2 doesn't help to solve this issue.
    Is it any way to restore functionality?

  • knocteknocte GBMember ✭✭

    @NinaKharchenko said:
    Ide log contains following:

    WARNING [2016-03-01 12:42:15Z]: Unregistered TargetFramework '.NETFramework,Version=v4.5.1' is being requested from SystemAssemblyService, returning empty TargetFramework

    Seems similar to https://bugzilla.xamarin.com/show_bug.cgi?id=37977

  • BerayBentesenBerayBentesen TRUniversity ✭✭✭✭

    Source control (using ...) is not appear with the latest update on alpha channel. ( Did not update Xamarin studio)

  • OddbjornBakkeOddbjornBakke NOMember ✭✭

    Got new build from alpha channel now XS 6 build 4761.
    Don't know whats new. :open_mouth:

  • TamasMatraiTamasMatrai HUUniversity ✭✭

    Do you have any info about quickfix feature in Xamarin Studio Mac? It is missing for a while, now updated to the last version via alpha channel, and still have this bug.

  • OddbjornBakkeOddbjornBakke NOMember ✭✭

    @TamasMatrai said:
    Do you have any info about quickfix feature in Xamarin Studio Mac? It is missing for a while, now updated to the last version via alpha channel, and still have this bug.

    Can't find any release notes. But I guess the
    https://developer.xamarin.com/releases/studio/xamarin.studio_6.0/xamarin.studio_6.0/
    will be updated soon.

  • ZoltanSokiZoltanSoki USMember

    Seems like https://bugzilla.xamarin.com/show_bug.cgi?id=38970 is fixed! You can add new files as normal if you had problems with that.

  • DavidDancyDavidDancy AUMember ✭✭✭✭

    I just tried it and it appears that the crashing bug when editing XML attributes has been fixed. In fact it's very nice to have much fuller Intellisense when editing XAML form layouts now.

  • DavidDancyDavidDancy AUMember ✭✭✭✭

    I think I spoke too soon. The problems in the XML editor have definitely been fixed, but now I have a series of breakpoints in bound commands and properties that refuse to be triggered, no matter what.

  • OddbjornBakkeOddbjornBakke NOMember ✭✭
    edited March 2016

    Se there is another new alpha 6.0.0.4801

    Also like the new way of showing the changes in: https://developer.xamarin.com/releases/studio/xamarin.studio_6.0/xamarin.studio_6.0/

  • JonBoyzJonBoyz USMember

    With the latest alpha I cannot create the release Android package. Any idea?

  • LluisSanchezLluisSanchez ESXamarin Team Xamurai

    @JonBoyz which error do you get? can you file a bug report?

  • JonBoyzJonBoyz USMember

    I get no error, I cannot find the menu entry.

  • LluisSanchezLluisSanchez ESXamarin Team Xamurai

    @JonBoyz You should have an "Archive for Publishing" option in the context menu of the project, and also on the Project menu of the main menu bar.

  • JonBoyzJonBoyz USMember

    This is a strange wording and function. I dont would like to create a archive or other things, I only need a simple package to send it to 1 or 2 testers. :(

  • DomCSDomCS DEMember ✭✭

    Please bring this button back. I always found it to be a really good experience. Keep right-click if you want but add this more explicit redundancy.

  • knocteknocte GBMember ✭✭

    Does anyone have trouble updating XS for Windows? I reported a bug about this here: https://bugzilla.xamarin.com/show_bug.cgi?id=39880

    So I'm stuck in build 4761... :(

    And today I tried to run some NUnit3 tests and it didn't work. But not sure if the latest NUnit3 fixes are included in my version, or should I report a bug?

    Thanks

  • knocteknocte GBMember ✭✭

    Nevermind, just closed my bug (check the latest comment in it if you're curious).

  • mhutchmhutch USMember, Xamarin Team Xamurai

    @JonBoyz we're standardizing on the the Archive->Publish workflow for both Android and iOS. It's consistent, allows correctly re-signing the package for various distribution channels, and preserves symbols for symbolication.

  • DavidDancyDavidDancy AUMember ✭✭✭✭

    @mhutch For those of us who need to do headless builds, how do we find out the calls and parameters needed to make the headless build use the settings in the corresponding project file?

    In my current script, I have to "manually" jarsign and zipalign the .apk file produced by the build command even though I've specified the keystore and password in the project file of the app. In fact I've automated the process by reading the XML of the project file to find out what the settings are, then fed those into the jarsign and zipalign commands. It would be really nice to have some more support from the build system for this process.

  • mhutchmhutch USMember, Xamarin Team Xamurai

    @DavidDancy the build process is (to some extent) documented here: https://developer.xamarin.com/guides/android/under_the_hood/build_process/

    Are you using the SignAndroidPackage target?

  • DavidDancyDavidDancy AUMember ✭✭✭✭

    @mhutch No. I built my own script using FAKE, and set it up so it can build an individual .csproj file for me within the solution. I need this because our app is a white-label app with each client's version implemented as its own project in the solution.

    The SignAndroidPackage target appears from the docs to only work with Release configuration, whereas I need it to also work for Debug and Ad-Hoc (principally because I need to receive GCM messages in the Debug and Ad-Hoc builds separately from the Production edition). So I run the jarsign and zipalign commands from the script after building the .apk file for the appropriate compiler configuration.

  • Any news on a next (preview) release (including the Xamarin For All)?

  • JonBoyzJonBoyz USMember

    Now we have to say "R.I.P. Xamarin Studio for Windows". :( Before I install 200 GB Visual Studio scrap on my PC, I buy a Mac Mini.

  • mhutchmhutch USMember, Xamarin Team Xamurai

    @DavidDancy configurations are arbitrary and the names have no special significance to the tooling - you can have as many configurations as you want. You can't distribute an APK that uses the shared development runtime, but you can set whatever other configuration properties you want. I took a quick look at the MSBuild targets and I can't see that SignAndroidPackage depends on any configuration properties that only exist in Release. What problems are you seeing when you do that?

    FWIW it may be easier to follow if we move this discussion to another thread.

  • BrianMBrianM USMember ✭✭

    It seems that we have not had any new releases in two weeks. I have used this IDE since Preview 1 because of its speed and features. I expect since the Build conference, this has turned to a low priority. It might be time to change to the Stable channel in Xamarin Mac or use Visual Studio. I am going to the Evolve conference this month and I will hopefully get a good picture of the future of Xamarin Studio / Visual Studio with Xamarin.

  • LluisSanchezLluisSanchez ESXamarin Team Xamurai

    @BrianM We'll push a new alpha release very soon, today or tomorrow.

  • BrianMBrianM USMember ✭✭

    Thank you @LluisSanchez. This is such a great product and appreciate your quick response.

  • JonBoyzJonBoyz USMember

    @LluisSanchez said:
    @BrianM We'll push a new alpha release very soon, today or tomorrow.

    We get also a new Alpha for Windows?

  • IgorCamiloIgorCamilo USMember

    Hi, I just downloaded the latest Alpha and it is a great improvement. Congratulations! However, I'm having a minor issue with dropdown menus. I have to keep pressing the mouse down to see the options. Otherwise, they simply disappear. It happens in every dropdown menu in Xamarin Studio. Am I the only one experiencing this? Or should I open a bug report?

    Thanks

  • CTCHANGCTCHANG AUMember ✭✭

    I downloaded the XS6 but I failed to login with my Visual Studio Enterprise account in my MacBook. But I no problem with my community free account. Does anyone having this issue?

    Also, any idea when XS6 going to officially promote to release?

  • @CHIEWTHOUCHANG said:
    I downloaded the XS6 but I failed to login with my Visual Studio Enterprise account in my MacBook. But I no problem with my community free account. Does anyone having this issue?

    I understood from a support mail I received that XS6 does not support the Xamarin For All at the moment. There is an update needed for that for which we are waiting

  • There it is... Version 6.0 (build 4968) ... updates XS6 with new Icon!

  • And another Icon when you set it to Dark mode... :smile:

  • BrianMBrianM USMember ✭✭
    edited April 2016

    I just downloaded build 4698 and my Xamarin.Forms apps load and run just fine, so do my Xamarin.Droid apps, but my Xamarin.iOS apps install the app onto the emulator and then do not load. There is nothing in the application output or the call stack. The same code ran fine using the last preview and still runs fine on the stable channel. Is there anything in the logs I can check?

  • NealCulinerNealCuliner USBeta ✭✭✭

    My iOS app is dead too :(

  • BrianMBrianM USMember ✭✭

    Installing the latest stable build of Xamarin.iOS 9.6.1 (but keeping Xamarin Studio 6 4698) fixed my problem. It seems something broke in Xamarin.iOS 9.8.0.244.

This discussion has been closed.