Error when running app

I am new to this program and when I try to run it the emulator never goes to home screen and just stays on the boot screen with the image Android. I get this error when I run my app."Deployment failed because of an internal error: Unexpected install output: Error: Could not access the Package Manager. Is the system running?"


  • rmaciasrmacias USBeta, University ✭✭✭✭✭

    ARM emulators are extremely slow and take forever to boot up. If you still see the "Android" screen, it is still trying to boot up. You'll see the home screen eventually. But you won't be able to deploy until you see it. Try using an x86 based emulator. Those run much faster, still a little on the slow side, but bearable.

  • JeevaNadarajahJeevaNadarajah USMember

    Ruben was right! I just had to wait for my emulator to be ready before I deployed to it. That worked and I no longer have that "Could not access Package Manager error".
    Thank you!

  • Pavan.7638Pavan.7638 USMember

    I can't see an option to Create X86 based Emulators, Could you point me out how to create that?

  • CheesebaronCheesebaron DKInsider, University mod

    Either install Genymotion otherwise go to your Android SDK manager and download the x86 AVD images for a specific API. Remember to install HAXM as well it is also in the Android SDK manager.

Sign In or Register to comment.