Xamarin.iOS 9.3 preview for iOS 9.1, tvOS 9.0 and watchOS 2.0

SebastienPouliotSebastienPouliot CAXamarin Team Xamurai
edited October 2015 in Xamarin.iOS

Note:Xamarin.iOS 9.3 preview #2 for tvOS 9.0 and watchOS 2.0 is now available.

Xamarin.iOS 9.3.x introduce preview supports for iOS 9.1, tvOS 9.0 and updated previews for watchOS 2.0. Xcode 7.1 beta 2 is required to test the new features.

Those previews are very early, unsupported builds to allow developers to test the new features and platforms recently announced by Apple and for Xamarin to gather feedback and bug reports. Your help is very appreciated!

Links

Known issues

  • watchOS and tvOS API are not final, some type might be missing and some types might not be available (e.g. iOS only)
  • For device builds (both iOS and AppleTV) you must disable incremental builds in the project’s options;
  • Bitcode support is not enabled for any platform
  • No storyboard support for tvOS projects with the iOS designer or Xcode 7.1
  • tvOS MetalGame template gives a System.InvalidOperationException on launching on an AppleTV
  • watchOS2 and watchOS1 applications currently work only on watch simulator
  • watchOS debugging supported only for default mode in watch simulator
  • iOS template projects currently work on 32 bit devices (bug #34267)
  • iOS SpriteKitGameTemplate gives build errors (bug #34433)
  • VisualStudio support is not available for initial preview

Posts

  • KevWestKevWest USMember

    Can't add a reference to a PCL from a tvOS app?

  • SebastienPouliotSebastienPouliot CAXamarin Team Xamurai

    @KevWest Could you please file a bug report with the build logs (minimally) or a test case (even better) ? thanks!

  • JohnHairJohnHair GBMember ✭✭✭✭✭

    @SebastienPouliot thanks for this, I'll be taking a look at tvOS when I get a spare few hours!

  • JohnHairJohnHair GBMember ✭✭✭✭✭

    Not having much luck, created a new tvOS app with no changes, getting '/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/TVOS/Xamarin.iOS.Common.targets: Error: Could not find a usable Xcode app bundle in /Applications/Xcode.app/Contents/Developer (abc)
    and
    /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/TVOS/Xamarin.iOS.Common.targets: Error: The TVOS SDK version '9.0' is not installed, and no newer version was found. (abc)
    I created a new VM with a fresh Xamarin install for this...

  • KevWestKevWest USMember

    @SebastienPouliot - sure will do.

  • KevWestKevWest USMember

    @JohnHair make sure Xamarin Studio is looking at the correct location for the tvOS SDK. I had to manually change it to point to the Xcode 7.1 beta location (Preferences -> SDK Locations -> Apple)

  • JohnHairJohnHair GBMember ✭✭✭✭✭

    @KevWest Ah yes that may very well be it, I'll check when I get home tonight.

  • AlexanderPAlexanderP USMember ✭✭

    I am having an issue using one of the provided tvOS templates.
    I am using the one called SingleView App. When I try to debug it on the tvOS Simulator, I get the following error:

    /Users/lbuser/Projects/singeview/singeview/MTOUCH: Error MT5103: Failed to compile the file '/Users/lbuser/Projects/singeview/singeview/obj/iPhoneSimulator/Debug/mtouch-cache/main.x86_64.m'. Please file a bug report at http://bugzilla.xamarin.com (MT5103) (singe view)

    No modifications were made, I am using the template as it is.

  • JohnHairJohnHair GBMember ✭✭✭✭✭

    @KevWest That was it, Im now running the tabbed view template app in the AppleTV simulator! Im also waiting at home for my dev kit to arrive...

  • VincentDondainVincentDondain USXamarin Team Xamurai

    @AlexanderP Could you please fill a bug report with the IDE logs, your Xamarin Studio "about" section and a test case if possible. That would help me understand your issue.
    The Single View template seems to be working fine on my side.
    Thanks (:

  • AlexanderPAlexanderP USMember ✭✭
    edited October 2015

    I'll try to get the Single View template to work here.
    EDIT:
    Okay, I tried again - it failed with the same error. I will file the bug report now.

    EDIT2:
    Bug 34752 submitted

  • VincentDondainVincentDondain USXamarin Team Xamurai

    At this moment the "Starter" edition cannot be used to create tvOS applications.
    We'll enable this in a future preview.

  • You can't add a PCL reference to a watchOS 2 project either, bug filed: https://bugzilla.xamarin.com/show_bug.cgi?id=34897

  • CrustyEvanCrustyEvan US ✭✭
    edited October 2015

    Hi @SebastienPouliot Thanks for all the work on the TvOS libraries. I was working on bindings for MvvmCross and was looking at a way to create a new library. However Xamarin Studio doesn't support it yet.

    Can you elaborate what you meant with?
    But we're also looking at other avenues for easing managed code sharing across the Apple platforms.

    Or do you have any other ideas on how TvOs libraries should be created?

    Maybe some manuals edits?

  • SebastienPouliotSebastienPouliot CAXamarin Team Xamurai

    @CrustyEvan "libraries" is a term that's a bit overloaded today :-)

    Right now you should be able to build libraries, as-in .net assemblies, as they are not specific to tvOS (it's only reference to different assemblies).

    If you want to create binding projects then this will be enabled in our next preview. You can still do them manually (like old binding projects) and provide the flags manually to your project - but that can be a bit cumbersome.

  • IainSmithIainSmith GBUniversity ✭✭

    @SebastienPouliot awesome! Can get to work on tvOS app now.

  • @SebastienPouliot Is there any new on when the next preview will be available?

  • SteveLobdellSteveLobdell USMember

    So I've downloaded the preview versions of Xamarin studio and Xamarin.ios. I changed the apple sdk location in Xamarin settings to point to the location of the preview sdk. However, when I start a new tvos project, the dlls in the reference folder are still pointing to the frameworks/current version, not the frameworks/9.0.whatever that I have in the Xamarin settings, any ideas? Thanks

    Steve

This discussion has been closed.