Error building helloWorld application using xamarin.Forms

I am trying to run the hello forms application that visual studio creates when you select the Xamarin.Forms template.But I am getting lots of errors when I try to start the android version of the application.Here are some of the errors that I get :

Activate(java.lang.String,java.lang.String,java.lang.Object,java.lang.Object[]) in mono.android.TypeManager cannot be applied to (java.lang.String,java.lang.String,md5d4dd78677dce656d5db26c85a3743ef3.CarouselPageAdapter,java.lang.Object[])
mono.android.TypeManager.Activate ("Xamarin.Forms.Platform.Android.CarouselPageAdapter, Xamarin.Forms.Platform.Android, Version=1.3.3.0, Culture=neutral, PublicKeyToken=null", "", this, new java.lang.Object[] { });

cannot find symbol
symbol : method getClass()
location: class md5d4dd78677dce656d5db26c85a3743ef3.CarouselPageAdapter
if (getClass () == CarouselPageAdapter.class)

package android.support.v4.content.Loader does not exist
android.support.v4.content.Loader.OnLoadCompleteListener

all the other errors(total of 30) are like the errors above only with different class names.I already updated the support library from the android sdk manager but I still get these errors.What do you suggest I do?

Answers

  • AmirAmirAmirAmir USMember

    I am also getting new warning errors such as this one :

    android\app\Activity.class(android\app:Activity.class): major version 51 is newer than 50, the highest major version supported by this compiler

  • If I start a new Blank App (Xamarin.Forms.Portable) I get in Visual Studio 2015 1457 Errors. All errors are in Resource.Designer.cs
    Typical: CS0117 Resource is missing definiton of "Animation"

    global::Xamarin.Forms.Platform.Resource.Animation.abc_fade_in = global::Hello.Droid.Resource.Animation.abc_fade_in;

    NuGet shows Xamarin.Forms 2.2.031

    Did I something wrong?

  • AndreasHeertschAndreasHeertsch CHMember

    Reinstallation of Xamarin.Forms and VS2015 in Hyper V removed the errors

  • AndreasHeertschAndreasHeertsch CHMember

    nevertheless the reason was different.
    The AndroidManifest called a minSDKVersion, which was not installed.
    Change the minSDKVersion to an installed one or install the requested version via SDKManager.

    That there is no specific error msg but a cryptic termination of aapt is misleading.

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭

    I'm curious which version of the Xamarin.Android.Support nugets you have installed.
    Every time I update from the 23.0.1.3 version to 23.3.0 (notice the missing digit in that version number) all hell breaks loose with the 1457 resource error issues you mentioned. So I've been updating just the Xamarin.Forms nuget manually in NuGetManager console using the -IgnoreDependencies flag. But if you have found a resolution where you can update all of these and get the project to build I'd love to learn that trick.

Sign In or Register to comment.