The type 'Android.App.Activity' is defined in an assembly that is not referenced...

I'm getting this error upon trying to build the maps demo project. I see Mono.Android in the references section, have removed it rebooted and re-added with no success. I tried repairing mono with no luck...

I do see an update to Xamarin Studio that just won't install. I've tried a bunch of times to get it install...the installer runs for a few seconds then goes away and the update still shows up as available. Not sure if that's related but it might be.

Anybody know what's going on?

Answers

  • I should add the full error is the title of the post + "You must add a reference to assembly 'Mono.Android, Version 0.0.0.0, Culture=neutral, PublicKeyToken=null'.

  • So I was trying to use Xamarin's Google Map demo. I guess it's out dated or something but I went and tried their Google Maps V2 demo using the updated API and Google Play Services and didn't have the same issue there.

    Hope this helps someone in the future.

Sign In or Register to comment.