Published app problem on some devices.

mohammadomidvarmohammadomidvar USMember ✭✭
edited September 2015 in Xamarin.Android

Some users, specially users who have Samsung S and Note series devices with android lollipop, when open my app, a white screen is shown and after a few moments app closes (without any force stopped message).
The app works well on my device (android 4.2) and other ones such as Sony devices with android 5.0 or above.

I don't know what is the error. I've tried automatic signing app in visual studio and also manually signing. but nothing changed.
Can you help me?!

Answers

  • We have the same issue. App is alive because I saw our UDP requests in console but main screen is empty.

  • YkshLeoYkshLeo USMember ✭✭✭✭

    @mohammadomidvar, @PatrickFradin

    Did you try to debug with the device connected ?

    Did you notice any exception ?

  • Yes. We worked with Xamarin.Studio or Visual Studio connected to the device.

    We noticed no exception. This is a problem. Our application seems to be alive because we can talk via an UDP connection to another remote device we control. We saw only the Main title of our application at the top.

    We have changed Main activity theme but only toolbar color changed, the rest of the UI is empty.

  • mohammadomidvarmohammadomidvar USMember ✭✭

    @Yksh.Leo
    This is reported by users and I'm not able to test debugging on their devices.

  • I joined console content as .zip file. Hope the helps some guru to help me...

  • We found the origin of the issue:

    System.Net.NetworkInformation.NetworkInterface.GetAllNetworkInterfaces will go in an infinite loop with Lollipop...

Sign In or Register to comment.