Communication issues from Windows 8 to Mac Mini

JonSkeetJonSkeet Jon SkeetUSMember

I'm just starting trying to use Xamarin.iOS, building in Visual Studio with a build host of a brand new Mac Mini.

Various bits of version information:

PC:

  • Windows 8 Professional, x64 (Core-i7), 8GB memory
  • Visual Studio 2012 Professional, Update 2
  • Xamarin.iOS 1.2.121
  • Xamarin.Android 4.7.09001

Mac:

  • Mac Mini Core-i5
  • XCode 4.6.3 (so hopefully not the 4.6.2 issue I've read about)
  • Xamarin Studio 4.0.9
  • Xamarin.Android 4.7.9
  • Xamarin.iOS 6.3.5.43

(I've tried various different versions, which behave in the same way.)

Xamarin Business Licence (.iOS, .Mac, .Android) - activated in the normal way on Windows, but out of desperation I've activated it manually on the Mac (by downloading the licence file).

Both machines are connected via ethernet on the same local network. The Mac has no firewall on (which is alarming in itself, to be honest). Windows just has the normal firewall configuration - nothing out of the ordinary.

I've managed to start Xamarin Studio on the Mac Mini, and debug the master/detail demo on the iPad simulator. The problems come when I try to use it as a Build Host from the PC.

In Visual Studio, under Options / Xamarin / iOS Settings, Current Mac Build Host, Configure, the dialog does see my Mac - but it has problems communicating with it. In the list, it either shows it as Unreachable, or Not Activated. When I click on Diagnose, it's fine until the "Establishing a stateful connection to Mac build host via HTTP" - that usually works (but not always), but takes a long time - a suspiciously long time. The "Comparing Remote and Local MonoTouch SDK" part always fails, but I've never been prompted to update either system to get them in sync.

The activation part usually comes up green now, but until I manually activated it, I could hit the "Activate" button as many times as I wanted, but I only saw "Unable to connect to the remote server" - which is also what I get when trying to launch an application.

It definitely sounds like a network issue somewhere, but I can't tell where - especially as it sometimes seems to get through. Any further diagnostics I should try to perform?

Best Answers

Answers

  • ChrisHardyChrisHardy Chris Hardy GBForum Administrator, Xamarin Team Xamurai

    Good to see you managed to get this figured out, Mac machines like to hide windows behind windows, unhelpfully, but I'll get this info back to the team to see if there's anything we can do to help in the future.

  • JonSkeetJonSkeet Jon Skeet USMember

    Looks like I spoke a little too soon. Anything I tried resulted in the simulator just sitting there, so I thought I'd reboot. Then I was back to it thinking it required activation... then going through the Diagnose step, it thought it was out of date again.

    Now when trying to launch the debugger, it's sitting at "Starting debug session..." while the Mac has a blank-screened iPhone or iPad. Eventually, I get: "Server returned an error. The request was aborted: The operation has timed out." (on the Windows side).

    It definitely feels like the communications are on the flaky side. Would you expect the "Establishing a stateful connection to Mac build host via HTTP" step to be quick during the diagnosis phase? I'm wondering whether there's some glitch in the network which is fouling just enough up to make it all flaky.

    Further diagnosis? Are there logs I should look at? Wireshark traces? Apologies for being completely out of my depth here...

    (Off to bed now anyway, so no urgent rush :)

  • josemiguel.torresjosemiguel.torres Jose Miguel Torres ESXamarin Team Xamurai
    edited June 2013

    Hi @JonSkeet,

    The "Establishing a statefull..." step is not expected to be quick. Actually is the one that ensures that the connectivity is absolutely possible and it may take some extra seconds.

    In order to get further details, we should take a look at the Mac build host log. This file is at ~/Library/Logs/Xamarin/MonoTouchVS/mtbserver.log. Please, could you gist or paste the content you think it could help us to figure out what's happening?

    Thanks

  • JonSkeetJonSkeet Jon Skeet USMember

    Hi @jtorres,

    Thanks for the extra info. I'm getting various log lines like this:

    [17-Jun-2013 22:32:03] Handling with command: [DebugApplication: CommmandUrl=DebugApplication] (10)
    [17-Jun-2013 22:32:03] Attempting to acquire command execution lock, timeout set to 00:10:00
    [17-Jun-2013 22:32:03] WaitForAppConnected
    [17-Jun-2013 22:32:03] Starting /Developer/MonoTouch/usr/bin/mtouch -sdkroot "/Applications/Xcode.app/Contents/Developer" --devname "iPad 6.1" --launchsim "/Users/jon/Library/Caches/Xamarin/mtbs/builds/HelloPad/97d55f95-07c8-455e-bf2b-7b9aa5353855/output/Debug/iPhoneSimulator/HelloPad.app" -stdout "/Users/jon/Library/Logs/Xamarin/MonoTouchVS/Simulator/HelloPad/97d55f95-07c8-455e-bf2b-7b9aa5353855/out.log" -stderr "/Users/jon/Library/Logs/Xamarin/MonoTouchVS/Simulator/HelloPad/97d55f95-07c8-455e-bf2b-7b9aa5353855/err.log" --device 2 -argument=-monodevelop-port -argument=49410 -sdk 6.1
    [17-Jun-2013 22:32:06] stderr: warning MT0001: '-devname' was provided without any device-specific action

    [17-Jun-2013 22:32:06] stdout: Starting iOS simulator 6.1

    Launching application

    ERR: There was an error launching the application: iOS Simulator failed to install the application.

    It's not clear to me whether the -devname warning is related to the "iOS Simulator failed to install the application" part.

    I reset the simulator, relaunched from VS, and this time the log contained:

    ERR: There was an error launching the application: The simulated application quit.

    No idea whether that's helpful or not, but I guess it suggests moving on to a different log file?

    Just to reiterate an earlier point, I was able to launch an app on the simulator from Xamarin Studio running on the Mac - but now even that's failing (in the same way - I get to try to relaunch the simulator, but that's all). Looks like I've messed the whole system up somehow :(

    Maybe tomorrow I'll work out what I need to reinstall or clean up...

Sign In or Register to comment.