MTOUCH: Error MT4109: Failed to compile the generated registrar code.

Hey guys,

Im trying to build my app for release but its failing for IOS build.

What can i do?

Full error:

MTOUCH: Error MT4109: Failed to compile the generated registrar code. Please file a bug report at http://bugzilla.xamarin.com (MT4109) (TestProject.iOS)

Posts

  • RolfBjarneKvingeRolfBjarneKvinge USXamarin Team Xamurai

    Have you filed a bug report as the error message requests?

  • RolfBjarneKvingeRolfBjarneKvinge USXamarin Team Xamurai

    You're building with the iOS 7.1 SDK:

          SdkVersion: 7.1
    

    and using a type introduced in iOS 8 (UIAlertController).

    You need build with the latest (or default) SDK (you can select this in your
    project's iOS Build options).

  • Hmm ok, when i get home i will test it and report it. Thanks so far!

  • PatikPatik USMember ✭✭

    Hello Did you find solution ?

  • ManojkumarMaliManojkumarMali USMember ✭✭✭

    I had the same issue while building app on mac machine.

    I resolved this issue by updating Xamarin.Ios on mac machine.

  • MagduszMagdusz PLMember

    I also resolved the problem with updating Xamarin on my Mac.

  • alextnalextn USMember ✭✭

    I had this problem, I resolved it by re-installing Xcode from the App Store !

  • ManojkumarMaliManojkumarMali USMember ✭✭✭

    Hi. My xamarin ios is up to date. but still getting same error. Please help

    Make sure that your Xamarin.Ios version matches with Mac machines version.

  • VivekNigamVivekNigam USMember ✭✭

    @ManojkumarMali said:

    Hi. My xamarin ios is up to date. but still getting same error. Please help

    Make sure that your Xamarin.Ios version matches with Mac machines version.

    Hi , thanks for replying. My mac version is macOS Sierra version is 10.12.5 and my xamarin.ios version is 11.3.0.47(51128b8)

    some of the project is build is successfully build but one of my project is giving the above error .

    Please help

  • VivekNigamVivekNigam USMember ✭✭

    @ManojkumarMali said:
    I had the same issue while building app on mac machine.

    I resolved this issue by updating Xamarin.Ios on mac machine.

    Hi,

    i have updated my Xamarin.IOS as well as the Xcode 9.0 still getting the same error.
    do i need to do somthing more updates or anything else.
    do i need to update the MAC PC too ??

    Please help.

  • JGoldbergerJGoldberger USXamarin Team, University Xamurai

    @VivekNigam said:

    i have changed the sdk to default but still same error is getting. Please help

    Can you post your version info from Visual Studio? If using VS Windows, please provide the version info for both VS Windows and VS Mac.

    In Visual Studio (Mac), version information can be obtained by navigating to: Visual Studio -> About Visual Studio -> Show Details -> Copy Information button.
    In Visual Studio (Windows), version information can be copied from: Help -> About Microsoft Visual Studio -> Copy Info button.

  • KapilKapil USUniversity
    edited November 2017

    Switch your XCode version in Xamarin > Preferences and Restart XamarinStudio or other softtware that you are using.

    Terminal Command : sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer

  • alextnalextn USMember ✭✭

    @VivekNigam said:

    @alextn said:
    I had this problem, I resolved it by re-installing Xcode from the App Store !

    Hi,

    i have updated my Xamarin.IOS as well as the Xcode 9.0 still getting the same error.
    do i need to do somthing more updates or anything else.
    do i need to update the MAC PC too ??

    Please help.

    As I said I uninstalled Xcode and installed it again; I have currently Xcode 9.0.1, Xamarin Studio 6.3 and Xamarin.iOS 11.2.0.11.

    Also why did you report my post for spam ? (also why asking my help if you report my posts..)

Sign In or Register to comment.