Xamarin.iOS 9.0.1.18 linker error

LGMaestrelliLGMaestrelli BRMember ✭✭✭

After the update, when I set the linker option to "Link Sdk assemblies only" I got this error:

"Could not link assemblies. Reason: Can't not find the nested type '<<.ctor>b__5>d__9' in 'Useall.E2.Comercial.AV.Mobile.Infra.Componentes.UseSearchField.UseSearchFieldView`1"

My class is like this:

public class UseSearchFieldView : ContentPage
{
public UseSearchFieldView(UseSearchField _searchField)
{
//Code
}
}

It was working fine on the release for iOS 8.4...

I'm using Windows 8.1
Visual Studio 2013 Update 5.
Xamarin 3.11.1443.0
Xamarin.iOS 9.0.1.0

On the Mac (10.10.5)
Xcode 7.
Xamarin.iOS 9.0.1.18
Build host 3.11.0.1442
Xamarin Studio 5.9.7

I'm not able to deploy any application with the linker option different from "Don't link"...

Tagged:

Posts

  • CarlBartonCarlBarton USInsider, University, Developer Group Leader ✭✭

    I have this same issue as well with what appears to be the same configuration. I get the error in VS.

    I tried to do a clean and run on Mac XS but was building for 15 minutes so I had to Force Quit. This is happening every time in XS.

  • MichaelRumplerMichaelRumpler ATMember ✭✭✭✭✭

    I get a similar error in my Xamarin.Forms app. I downgraded to Xcode 6.4 again, but it still doesn't work.

    When I choose "Don't link", then I get 9 errors like

    Your application is using the 'Contacts' framework, which isn't included in the iOS SDK you're using to build your app (this framework was introduced in iOS 9.0, while you're building with the iOS 8.4 SDK.) This configuration is only supported with the legacy registrar (pass --registrar:legacy as an additional mtouch argument in your project's iOS Build option to select). Alternatively select a newer SDK in your app's iOS Build options.

    The 9 errors are all about different frameworks, but I never used any of them.

    In my project properties / iOS Build / SDK Options I only have 8.4. 9.0 is not available so I cannot do what the error proposes. Should I try that with Xcode 7 again?

    When I choose "Link all assemblies", then the app deploys, but does not run. It crashes immediately because some essential methods have been removed.

  • LGMaestrelliLGMaestrelli BRMember ✭✭✭

    I was about to start a downgrade to test, but after your post I will not do that...

    That is a serous headache...

  • MichaelRumplerMichaelRumpler ATMember ✭✭✭✭✭
    edited September 2015

    I switched to Xcode 7 now and "Don't link" works for me. At least I can compile+deploy again. But without linker I don't even want to know how big my XF app gets ...

    I deployed my last version to Testflight yesterday, so there is no immediate need for that either, but by the middle of next week at the latest I need it.

  • GuiWaltrickeGuiWaltricke BRMember ✭✭

    Getting the same error here... no one from Xamarin say nothing....

    there are some people with the same problem: http://forums.xamarin.com/discussion/51127/new-error-after-updating-all-xamarin-packages

  • CarlBartonCarlBarton USInsider, University, Developer Group Leader ✭✭

    I was able to roll back to Xcode 6.4 and the previous versions of XS, VS and Xamarin.iOS and I am functional again (though no longer targeting iOS9). Except that I cannot debug on my iPhone6 device because it is on iOS 9 now.

    If I update to Xcode 7 but stay on Xamarin.iOS 8.x, do you think I would be able to debug 8.4 apps on my 9.0 device? Here is the error I get when attempting to debug on the device after the rollback:

    warning MT1108: Could not find developer tools for this 9.0 (13A344) device. Please ensure you are using a compatible Xcode version and then connect this device to Xcode to install the development support files.
    error MT1007: Failed to launch the application 'com.yourcompany.XXXXX' on the device 'My iPhone': Look for earlier warnings returned: 0x454. You can still launch the application manually by tapping on it.

  • LGMaestrelliLGMaestrelli BRMember ✭✭✭

    @CarlBarton

    I never had to do something like this, but I think that Xamarin.iOS will not locate the iOS SDK correctly...
    When I update my Xcode to version 7, I tried to do without updating Xamarin.iOS (the version was in beta) and I couldn't make work...

  • CarlBartonCarlBarton USInsider, University, Developer Group Leader ✭✭

    Thanks for the info. Thankfully I won’t be publishing any of the apps I have in progress for a while so I can wait until this gets resolved before trying again.

  • LGMaestrelliLGMaestrelli BRMember ✭✭✭

    I was planing to publish today :/
    But not anymore...

    On each Xamarin update I lose about a year from my life expectancy. Too much stress

  • KevinCKevinC USMember ✭✭

    Seems like someone already created a bug report.

    https://bugzilla.xamarin.com/show_bug.cgi?id=34063

    I've added some of my details to it too. Let's see if we're having similar error output.

  • SebastienPouliotSebastienPouliot CAXamarin Team Xamurai

    AFAIK this issue only happens when using Microsoft's csc from VS 2013. IOW a quick workaround is to use XS (mono's mcs on the Mac) or VS 2015.

  • LGMaestrelliLGMaestrelli BRMember ✭✭✭
    edited September 2015

    @SebastienPouliot

    Thanks for the reply.

    I will try it.

  • SebastienPouliotSebastienPouliot CAXamarin Team Xamurai

    It also seems to be related to the debugging .mdb file (generated on windows and copied to the Mac). All release builds (with the test cases we have so far) are working fine.

    @LGMaestrelli it should all be covered in the installation instruction for the Mac.

  • GuiWaltrickeGuiWaltricke BRMember ✭✭

    @SebastienPouliot do you know about some fix without change to XS? thanks

  • SebastienPouliotSebastienPouliot CAXamarin Team Xamurai

    @GuilhermeWaltricke right now it seems that:

    • release (non debug) builds; and
    • VS2015 builds (which has a different csc compiler)
      both works fine.
  • LGMaestrelliLGMaestrelli BRMember ✭✭✭

    @SebastienPouliot

    Here, I have the error on debug AND release. On real device or simulator.
    I just have to set the linker different from "Don't link" and rebuild the project.

  • SebastienPouliotSebastienPouliot CAXamarin Team Xamurai

    @LGMaestrelli make sure your settings are not generating debugging files (.pdb files that converted into .mdb files). That's the default for release builds - but the options can be changed to enable them.

  • LGMaestrelliLGMaestrelli BRMember ✭✭✭

    @SebastienPouliot

    The debug option is not checked for release.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    To help consolidate further updates about this particular bug, I will now close this thread, and leave a link to the current release announcement, where this issue is now being tracked under Bug 33124:

    http://forums.xamarin.com/discussion/50971/stable-release-xamarin-ios-9-0-ios-9-0-upstream-release/p1

    As discussed on that thread, unfortunately when using pre-built libraries (e.g. NuGet packages or Components) that were built using VS 2013, the workaround of disabling debug symbols does not seem to be effective. The Xamarin developers are creating a follow-up build to fix this issue that will be released within the next few days.

This discussion has been closed.