Hints for update WP 8.0 -> WP 8.1

FredyWengerFredyWenger ✭✭✭✭✭CHInsider ✭✭✭✭✭

Hi all
I'm on the way to update my WP-app in the windows app store.
In the meantime (after my first submit of the WP 8.0 app):

  • MS has migrated their dev-portal (I was not able to access it for about two weeks)
  • I have updated from 8.0 to 8.1

Now, I wanted to update my app in the new Windows Dev Center...
Thereby I had / have some problems (wasted about 5 hours until now)...

Therefore I write this message (to help other developers save time)...

It seems as - with the WP 8.1 migration a new file named PackageAppxmanifest take place (I don't remember to have seen it before).
This file contains some important data, that have to be correct and seems to be false per default.
Further, it seems as there are some new images, that **have to ** be replaced with your own files.

By my tries to update the package, I received strange error-messages and then searched for the values in the file-explorer in the WP project...
=> So I have found the PackageAppxmanifest-file...
I then have edited the PackageAppxmanifest-file with an editor and changed the "false" values (from error-message in the Dev Center) thru the "expected" values in the error-messages (by copy-paste from Dev Center).

Then I was able to submit the package...
After about 10 minutes I had a "certification-error"

Error-Messages and file-names:
Image file StoreLogo.png is a default image.
=> 120 x 120 Pixel, 32 Bit”
Image file Logo.png is a default image.
=> 106 x 106 Pixel , 32 Bit
Image file SquareTile71x71.png is a default image.
=> 170 x 170 Pixel , 32 Bit
Image file SquareTile150x150.png is a default image.
=> 360 x 360 Pixel, 32 Bit

The (empty) file-templates are stored under the **\Assets** subfolder of the WP project.
This files are "empty" per default
=>I replace them tomorrow and hope. the package then will be accepted

By my searches for the name of one if the new images, I found this very useful blog that explains the problems:
http://blog.devmatter.com/migrating-wp-8-0-apps-to-wp-8-1/

I wonder (one more time!) that I don't have found such information's here in the XF forum :disappointed:
But maybe, I don't have searched enough :smirk:

However... hope this helps someone and my app will be accepted, after I have changed the new images

Cheers :sunglasses:

Posts

  • RaphaelSchindlerRaphaelSchindler ✭✭✭ USMember ✭✭✭

    I don't wonder that you haven't found something here. WP isn't the best supported platform even with XF.

  • FredyWengerFredyWenger ✭✭✭✭✭ CHInsider ✭✭✭✭✭
    edited September 2015

    Yes... but now you will find some information's, (if you search for the right words :wink:)

    Additional link with some useful information's to the new images:
    http://stackoverflow.com/questions/25514918/windows-phone-8-1-assets

  • FredyWengerFredyWenger ✭✭✭✭✭ CHInsider ✭✭✭✭✭

    Important:
    I had incredible problems (once again) to update my existing WP 8.0 app with the new WP 8.1 app.
    I ended in submit my app once again (completely new package -> all users that have downloaded the app already are lost).

    The effect was, that the app don't start after the update.

    The problem is caused by a bug in the WP 8.1 OS and pop's, if the app has an "Identity Name" of 50 characters.

    If you ship your WP-app the first time to the MS dev center, take care, that your "Application Name" is not very long, and check that the (from the "Application Name" generated) "Identity Name" is shorter than 50 characters (you can see this in the dev center) before you ship your app to the store in the MS dev center.

    If you have defined a long Application Name to your WP app already (display name, reserved name) and/or have this problem (app don't start after update), I strongly suggest you, to read also the thread below:
    http://forums.xamarin.com/discussion/52100/wp-8-1-deploy-error-package-could-not-be-registered-after-update-from-8-0#latest

    Hope, this helps someone...

Sign In or Register to comment.