Forum Xamarin.iOS

Start debugging not enabled (grayed out)

Hi everyone.

I've upgraded the Xamarin Studio and Xamarin.iOS because I've not used them for months.

After that I have these version:
Xamarin Studio Version 5.9.5 (build 10)
Xamarin.iOS Version: 8.10.4.46

Now I'm trying to debug an application through an iPhone but the "Start debugging" button is disabled.
It is possible to run the app in the iPhone but without debugging.

image

How is it possible to enable this button to debug the app through an iPhone?

Answers

  • maxmattini.3628maxmattini.3628 AUMember
    edited September 2015

    Have same problem. It is very much appreciated if Xamarin post an answer or fix the problem.

    please note: Yesterday, I did upgrade Xcode to version 6.4.
    Update: Upgrading to the latest xamarin (Studio 5.9.6, Xamarin.iOS 8.10.5.26 (indie), Xcode 6.4, Mac OS 10.10.5), **did not fix the problem. **

  • RogierKoningRogierKoning ESMember ✭✭

    I'm still having the issue with Studio 5.9.6 and Xamarin.iOS 8.10.5.26 (indie) like @maxmattini.3628 said.
    I'm going to install last beta version to try it...

  • Just a checklist which can fix the problem:

    • Make sure the solution has a start project (right mouse button the select 'Set as startup project')
    • Make sure that if you are using an Indie license (which does not allow you profiling) to check you 'iOS build' section for the desired configuration. Make sure 'Enable Debugging' is checked (while 'Enable profiling' should be unchecked).

    In my case, I discovered that, by mistake the 'enable debugging' was unchecked.

  • RogierKoningRogierKoning ESMember ✭✭

    Thanks @maxmattini.3628 for pointing this list.

    With version Xamarin Studio Version 5.9.7 (build 9)
    Xamarin.iOS Version: 9.0.1.18 (Indie Edition)

    The problem continues.
    Checked that debugging is enabled and the solution has a startup project.
    image

    Please help!!!
    Could anyone guide me to solve this issue?

  • ColbyWilliamsColbyWilliams USXamarin Team Xamurai

    @RogierKoning, which project in your solution selected as the "Startup Project"? The Xamarin.iOS project (not a Shared project or PCL) must be selected as the "Startup Project" to debug the Xamarin.iOS project.

  • RogierKoningRogierKoning ESMember ✭✭
    edited September 2015

    Thank you @ColbyWilliams for answering.
    Yes, I've got the Xamarin.iOS project as the "Startup Project". I have 2 projects, one shared project (OxyPlot) and the main Xamarin project and have selected "Set as startup project" some times on my Xamarin.iOS project.

    I don't know if debugging is disabled because it is an old project. I'm trying to create a new Xamarin.iOS project to try it.
    I'm updating some libraries with iOSRefUpdater because they are compiled for older Xamarin versions and are giving me compiling errors.

    I'll post the result here.

  • XiaoFanXiaoFan CAMember

    I have the same issue. Any idea how to fix it? This issue only happens on couple projects.

  • XiaoFanXiaoFan CAMember

    well, actually, I am able to debug the projecet on the device, but not on the simulator.

  • I'm seeing the opposite problem that XioFan saw. I am able to debug with the simulator but not with the device. Since my app is crashing on the device and not in the simulator, this is a big problem for me. As described above, the "Start Debugging" is grayed out. I checked all the previous suggestions. Building with Xamarin Studio 5.10.1.

  • I resolved my issue. Pretty simple really. I enabled it by setting the configuration mapping for the startup project in Xamarin Studio - ->Configurations->Configuration Mapping

    It had never been apparent to me that the mappings on the right were drop downs. When I realized that and set the startup project to Debug|iPhone it allowed me to run in debug mode.

  • JoseRiveraJoseRivera USMember

    Non of the above solutions worked for me, after trying all of them I wasn't able to debug on a device. What solve my problem was to open the iOS .csproj file and under the PropertyGroup for 'Debug|Iphone' change the value of from True To False then reload the project. That did the trick!!

  • UmutBebekUmutBebek TRMember ✭✭

    It can be a problem that Mono is not installed via VS. I downloaded and installed it manually on Mac via
    https://www.mono-project.com/download/vs/
    and debugging enabled. Maybe that helps someone after years :)

Sign In or Register to comment.