Forum Visual Studio

Old problem with Xamarin activation in Visual Studio again

WojciechPazioWojciechPazio PLMember
edited August 2015 in Visual Studio

Hello,

I wanted to try Xamarin, unfortunately i can't start. When I try to log in in Visual Studio I got this error:
System.Exception: Could not load machine data: at Xamarin.Components.Ide.Activation.ActivationService.GetErrorWorkflow(LicenseSyncResult[] results, Boolean ignoreSyncErrors) at Xamarin.Components.Ide.Activation.ActivationService.<GenerateFullWorkflowSequence>d__88.MoveNext() at Xamarin.Components.Ide.Activation.ActivationDialog.DisplayWorkflowStep(ActivationWorkflowStep step) at Xamarin.Components.Ide.Activation.ActivationDialog.<>c__DisplayClass13.<StartSpinnerTaskAndScheduleContinuation>b__12(Task t)

I tried to find solution for this problem, There are few topics from 2013 and some posts from 2014. Fix what was mentioned in those posts is just try to reinstall it all again.

I have fresh installed Visual Studio 2013 Version 12.0.21005
I hope there is some solution for this error, I can't use Xamarin in VS but I can login to Xamarin studio with no problem.

Regards

Tagged:

Answers

  • WojciechPazioWojciechPazio PLMember

    I tried fresh installation VS2015 community, it has the same problem with activation.
    I've upgraded Windows8.1 to Windows10 recently, so I create Windows8.1 virtual machine in Hyper-V and there are no problems with activation, works like a charm.

    I will try to reinstall it all again on Windows10. I'd prefer to work on host not on guest, but it looks like there is some problem with W10

Sign In or Register to comment.