Forum Visual Studio

Unable to run apps in Android Player using Xamarin Studio

samratmitrasamratmitra USMember
edited August 2015 in Visual Studio

Dear Exparts

I have created Android apps in Xamarin Studio. But for some need I have to install Visual Studio 2015 Community edition in to my system and updated Xamarin Studio as well, But the problem now is whenever I am trying to run my early developed Xamarin Android app program it is launching Android Player but in Xamarin Studio it is showing "Starting Nexus 5 ( KitKat )" or what ever the emulator name is and it is not moving forward .. refer to the image .

Can any one guide me on that...???

image

I have seen that like me so many users are facing same problem but It is most unfortunate that... no Xamarin expert is helping us to resolve that.... really frustrating. If you have bugs in latest build then why you people released the build..? No testing ..nothing.....

Posts

  • mattwardmattward GBMember Xamurai

    I have just seen this problem today. The first time I tried to run an Android app in the debugger on Windows it failed to run it in the Xamarin Android Player (XAP). After I closed XAP and re-ran the app again in the debugger it worked. I can repro the problem if I kill adb, close Xamarin Studio and XAP, and debug the Android app again.

    When it failed to start it I could see the following repeated every few seconds in the AndroidTools log:

    RunShellCommand: 10.71.34.101:5555 getprop
    

    What is in your AndroidTools log? You can find the logs by going to Help - Open Log Directory.

  • samratmitrasamratmitra USMember
    edited August 2015

    I have done all the process mentioned by you and I am getting errors same like

    [2015-08-27 14:29:07.6] DEBUG: RunShellCommand: 10.71.34.101:5555 getprop

    PFA the log file..

    Any Suggestions?

  • mattwardmattward GBMember Xamurai

    Would you be able to open a bug report on bugzilla? Attach the IDE log and the information from Help - About - Show Details. Thanks.

  • samratmitrasamratmitra USMember

    Yes Matt
    I just posted it to bugzilla... bug code is 33415

  • samratmitrasamratmitra USMember
    edited August 2015

    @mattward I have posted the bug in bugzilla - bug code 33415 but yet no reply received...

Sign In or Register to comment.