Don't link causing issues for submitting app

I'm trying to submit my app, but because of certain Nugets not working without Don't link selected i'm getting an error about the executable being too large. Anyone know a way to fix this or to only link some files?

Posts

  • ChristianFalchChristianFalch NODeveloper Group Leader ✭✭✭

    Are you sure it is the executable and not just the API usage report that is too big? Got this warning myself with an app that ended up as approx. 18 megs in the AppStore on iOS.

  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai
    edited August 2015

    @JoshuaNovak.6915,

    We don't typically recommend releasing an app with Don't Link as the linker setting. I would recommend using the Link SDK Assemblies option. If you are running into issues with your app when using that linker setting, let's figure those out instead.

    Link SDK Assemblies will reduce the size of the executable. You can also see which architectures are selected in the iOS Build -> Advanced tab and only target the ones you need. For example, Armv7 + Arm64 are pretty common and cover a wide range of modern iOS devices.

  • JoshuaNovak.6915JoshuaNovak.6915 USMember ✭✭

    @John.3665 I am already using Amrv7 + ARM64. I tried setting the build to Link SDK Assemblies, but my SVGs aren't showing up. I'm using Xam.Plugins.Forms.Svg.

  • JoshuaNovak.6915JoshuaNovak.6915 USMember ✭✭

    @John.3665 Is there a way to link that specific Nuget? Also it has embedded resources in the main project, not sure if that would cause an issue.

  • JoshuaNovak.6915JoshuaNovak.6915 USMember ✭✭

    @ChristianFalch It may still work. Is there anyway to tell what size it will be beforehand? Trying not to get rejected. Also, did you have any luck trying validation in Xamarin Studio?

Sign In or Register to comment.