Alpha Release: Xamarin.Android 5.1.99, Cycle 6 Preview

BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
edited October 2015 in Xamarin.Android

This thread has now been closed to direct all further updates about this release onto the latest announcement:

http://forums.xamarin.com/discussion/52444/alpha-release-xamarin-android-6-0-cycle-6-feature-release/p1


Windows

  • Xamarin.VisualStudio_4.0.0.1505.msi (9ac5fb8)

Mac

  • mono-android-6.0.0-2.pkg (537132d)

Reason for release: Preview of the upcoming Cycle 6 feature release, in particular to gather as many additional customer bug reports as possible. (See the release blog and "Xamarin Release Cycles" for more information about "Cycles" and "Service Releases.")

Release notes: http://developer.xamarin.com/releases/android/xamarin.android_5/xamarin.android_5.1.99/

Date published: See https://releases.xamarin.com/.

NOTE: These Alpha versions have some known open bugs, and they have not yet completed the full suite of tests by the Xamarin QA team. The reason for this release is to gather as many additional customer bug reports as possible. (See also guideline #2 below.)

Previous versions, downgrading

You can downgrade back to the current Stable version by switching updater channels.

Guidelines for this thread

  1. This first post will be updated regularly.

  2. If you find a new problem that is specific to this version:

    a. If you can share some specific error messages or can reproduce the problem consistently, please email the information you have so far to contact+cycle6preview@xamarin.com.

    b. If you only have a general description of the problem, you can post it directly on this forum thread so that hopefully a member of the Xamarin team or another user will recognize it and be able to help fill in some details.

Important changes

  • [Xamarin Studio] [Visual Studio] [iOS] [Android] Support for OS X 10.9 Mavericks has been deprecated. The Cycle 6 builds now require OS X 10.10 Yosemite.

New issues in the Alpha builds reported by users in the forum announcements

  • Non-public Bug 33465 - [Android] "Error MSB4018: The "MergeResources" task failed unexpectedly."

Remaining known issues from Cycle 5, with more common or severe issues near the top

  • Non-public Bug 30481, Bug 29557 - [Mono] [Android] [iOS] SqlConnection.GetSchema() fails with "SourceTable is required to be a non-empty string".

  • Bug 30548 - [Android] Under certain conditions new threads take several seconds to start. This problem seems to be triggered by Xamarin.Insights 1.10. Partial workarounds: upgrade Xamarin.Insights to version 1.10.3, downgrade to version 1.9, or remove it entirely.

  • Bug 29731 - [Android] Android.Bluetooth.BluetoothAdapter.Enable is incorrectly marked as [Obsolete("deprecated")] for API level 20 and higher.


EDIT Sep 02: Update for new Alpha builds. The Windows installers are now available.
EDIT Sep 03: Add Android Bug 33465.
EDIT Sep 08: Remove Android Bug 30513 because it's fixed.
EDIT Sep 10: Adjust the "guidelines" to mention contact+cycle6preview@xamarin.com.
EDIT Sep 21: Update for Sep 18's new Alpha builds.
EDIT Sep 24: Update for new Alpha builds.

Posts

  • Hi,

    Got a build error when updating to this latest Xamarin.Android:

    /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: Error: Error executing task MergeResources: Object reference not set to an instance of an object (HundData.Android)

    /Fredrik

  • KasperOvergrdNielsenKasperOvergrdNielsen DKBeta, University ✭✭

    Hi

    Got the same error as @FredrikNilsson

    /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/Android/Xamarin.Android.Common.targets: Error: Error executing task MergeResources: Object reference not set to an instance of an object (XamarinPoC.Android)

    /Kasper

  • Martijn00Martijn00 NLInsider, University ✭✭✭

    Same error for me:

    C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(2,2): Error MSB4018: The "MergeResources" task failed unexpectedly.
    System.NullReferenceException: Object reference not set to an instance of an object.
       at Xamarin.Android.Tasks.MergeResources.<MergeValues>c__AnonStorey0.<MergeValues>c__AnonStorey4.<>m__0(XElement d)
       at System.Linq.Enumerable.Any[TSource](IEnumerable`1 source, Func`2 predicate)
       at Xamarin.Android.Tasks.MergeResources.<MergeValues>c__AnonStorey0.<>m__2(XElement x)
       at System.Linq.Enumerable.<>c__DisplayClass0`1.<CombinePredicates>b__1(TSource x)
       at System.Linq.Enumerable.WhereEnumerableIterator`1.MoveNext()
       at System.Xml.Linq.XContainer.AddContentSkipNotify(Object content)
       at System.Xml.Linq.XContainer.Add(Object content)
       at Xamarin.Android.Tasks.MergeResources.MergeValues(String src, String dest, TaskLoggingHelper Log, Dictionary`2 sources)
       at Xamarin.Android.Tasks.MergeResources.CopyResource(String src, String destPath)
       at Xamarin.Android.Tasks.MergeResources.Execute()
       at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute()
       at Microsoft.Build.BackEnd.TaskBuilder.<ExecuteInstantiatedTask>d__20.MoveNext() (MSB4018)
    
  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Thanks for the reports! This "'MergeResources' task failed unexpectedly" error is being tracked in a non-public bug report, and will be fixed in a future "Cycle 6" build, at the latest before Cycle 6 is promoted to the Stable channel, but probably sooner than that. I will track its status in the the forum announcements as the builds are updated. For the moment, I have added it to the first post in the thread.

  • our company all computer same error..

    1. windows 10
    2. vs 2015 install
    3. xamarin alpha update
    4. deploy error

    Build started.
    2>C:\Program Files (x86)\Java\jdk1.7.0_55\bin\keytool.exe -list -alias androiddebugkey -storepass android -keypass android -keystore "C:\Users\kap\AppData\Local\Xamarin\Mono for Android\debug.keystore"
    2>C:\Program Files (x86)\Java\jdk1.7.0_55\bin\jarsigner.exe -keystore "C:\Users\kap\AppData\Local\Xamarin\Mono for Android\debug.keystore" -storepass android -keypass android -digestalg SHA1 -sigalg md5withRSA -signedjar bin\Debug\MtMate.MtMate-Signed-Unaligned.apk C:\Repos\MtMate\src\MtMateApp\MtMateApp.Droid\obj\Debug\android\bin\MtMate.MtMate.apk androiddebugkey
    2>No -tsa or -tsacert is provided and this jar is not timestamped. Without a timestamp, users may not be able to validate this jar after the signer certificate's expiration date (2045-07-22) or after any future revocation date.
    2>C:\Program Files (x86)\Android\android-sdk\build-tools\22.0.1\zipalign.exe 4 "C:\Repos\MtMate\src\MtMateApp\MtMateApp.Droid\bin\Debug\MtMate.MtMate-Signed-Unaligned.apk" "bin\Debug\MtMate.MtMate-Signed.apk"
    2>The "InstallPackageAssemblies" task failed unexpectedly.
    2>System.NotSupportedException: The given path's format is not supported.
    2> at System.Security.Permissions.FileIOPermission.QuickDemand(FileIOPermissionAccess access, String fullPath, Boolean checkForDuplicates, Boolean needFullPath)
    2> at System.IO.File.InternalGetLastWriteTimeUtc(String path, Boolean checkHost)
    2> at System.IO.File.GetLastWriteTime(String path)
    2> at Xamarin.Android.Tasks.InstallPackageAssemblies.Execute()
    2> at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute()
    2> at Microsoft.Build.BackEnd.TaskBuilder.d__26.MoveNext()
    2>Build FAILED.

  • OlegIlyinOlegIlyin USMember
    edited September 2015

    Guys, can you please finally figure out the status of Bug 30513. According to Comment 22 is is fixed already. But the bug is still open.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    @kapryeongkim, thanks for the report! I searched for existing bug reports with similar error messages, and did not find any, so I believe the developers would be quite interested to get a few more details from you to give them the best chance at reproducing and solving the issue you are seeing.

    If you get a chance, please send an email to contact@xamarin.com (or one of the support email addresses listed on https://store.xamarin.com/account/my/subscription) that includes the string "Cycle 6 Preview" in the subject, and attach as much of the following information as possible:

    1. Your diagnostic MSBuild output from a failed build.

    2. If possible, a zipped up project that demonstrates the problem. (You can delete the bin, obj, Components, and packages folders before creating the zip to save space.)

    Thanks in advance!

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    OlegIlyin, done. The QA team would have eventually done a verification pass on Bug 30513 (at the latest before the final Beta release of Cycle 6), but I went ahead and fast-tracked the verification by doing it myself (mostly just "for fun" since I'm on vacation this week :smile:).

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited September 2015

    The "InstallPackageAssemblies" task failed unexpectedly.
    2>System.NotSupportedException: The given path's format is not supported.

    Just for some quick cross-thread bookkeeping, I'll record here that the "InstallPackageAssemblies" exception mentioned above was also reported by another user on the corresponding XamarinVS release announcement. Based on that other report, it sounds like maybe attempting to deploy the "XLabs.Sample.Droid" app from the XLabs repository will have a decent probability of reproducing the issue.

  • PhilipGruebelePhilipGruebele USMember ✭✭

    Yes XLabs is an excellent way to reproduce errors. I highly recommend you make XLabs builds part of the build/deploy QA procedure.

  • I sent an email to contact@xamarin.com. The same problem occurs in all projects(include xamarin form template project).

  • Martijn00Martijn00 NLInsider, University ✭✭✭
    edited September 2015

    When installing the new update i get this error:

    Error 1609. An error occurred while applying security settings. Users is not a valid user or group. This could be a problem with the package, or a problem connecting to a domain controller on the network. Check your network connection and click Retry, or Cancel to end the install.

    I've attached the full log so you can inspect it. My guess would be that is related to this: https://support.gaaiho.com/hc/en-us/articles/201023667-Error-1609-while-applying-security-settings-Users-is-not-valid-group-

    My Windows has a group called "Gebruikers" which is Dutch for "Users".

    Edit:
    I've added a new group called "Users" myself now. The installer runs without problems after restarting the PC, and do a reinstall.

    If i now try to run our app again the same "MergeResources" error appears.

  • version 5.10 looks sweet, do we know when it will be available? i can't wait

  • OlegIlyinOlegIlyin USMember

    Building with Xamarin for VS 4.0.01372 / Xamarin Android 5.1.99.678 gives the following error:

    error APT0000: No resource found that matches the given name (at 'value' with value '@integer/google_play_services_version').

    This error appears when building class library with referenced GooglePlayServicesLib.dll. Upon build AndroidManifest.xml is generated in \resourcecache\26476C2E8DE887FC6F1DCEDBAA926AF0\AndroidManifest.xml

    Project is configured to min API10, compile - latest (API23) and target as compile. Tried to compile with Android SDK Build-tools 23.0.1 as well as Android SDK Build-tools 23.1 rc1

  • BerayBentesenBerayBentesen TRUniversity ✭✭✭✭

    When Non-public Bug 33465 will be fixed in alpha release ? I can not move project to 6.0 Thanks

  • Does 33465 have a workaround?

  • I'm not sure why but removing

    <item name="android:imeOptions">actionNext|flagNoFullscreen</item>

    from:

    `<style name="RecipientEditTextView" parent="@style/RecipientEditTextViewBase">
           <item name="android:imeOptions">actionNext|flagNoFullscreen</item>
        </style>`
    

    In a binding project I was referencing, fixed my MergeResources issue.

  • BerayBentesenBerayBentesen TRUniversity ✭✭✭✭

    Still waiting update for 33465 fix, you might update at least alpha version if you already fixed that right ? We do not need to wait stable release I guess.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    MergeResources Bug 33465 and several other resources errors fixed in the latest Alpha

    The new Alpha release from today reverts a set of experimental changes related to resources, one of which caused the MergeResources error.

    If you like, feel free to try the latest Alpha builds to check that they improve the behavior on your system, and if not please do file a quick bug report. Thanks in advance!


    On a side note, apologies also for dropping out of contact on this thread. The Xamarin.iOS 9.0 Stable release pulled me away from these Alpha threads for the past couple of weeks. Moving forward I will adjust my recommendation on these pre-Stable feature release threads to encourage direct bug reports. That will help distribute the follow-up investigation among the Xamarin QA and engineering teams and allow for more detailed discussion of specific symptoms.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    This thread has now been closed to direct all further updates about this release onto the latest announcement:

    http://forums.xamarin.com/discussion/52444/alpha-release-xamarin-android-6-0-cycle-6-feature-release/p1

This discussion has been closed.