Forum Visual Studio

Xamarin Studio crashes on startup

Jean-FrancoisPineroJean-FrancoisPinero CAMember ✭✭
edited August 2015 in Visual Studio

Hey guys, windows crashed on me and since reboot Xamarin Studio fails to start after the dreaded popup "Xamarin failed to start". I tried renaming the cache folder, re-installing Xamarin Studio but to no avail. Here is the crash log:

INFO [2015-08-25 15:16:14Z]: ANDROID: Found Android SDK. API levels: 10, 15, 16, 17, 18, 19, 20, 21, 22 INFO [2015-08-25 15:16:14Z]: Initial entitlements: Android Indie 2015-09-08 02:46:11Z INFO [2015-08-25 15:16:14Z]: Running license sync for Android Initializing Main Window INFO [2015-08-25 15:16:14Z]: Creating DefaultWorkbench ERROR [2015-08-25 15:16:15Z]: System.Xml.XmlException: Root element is missing. at System.Xml.XmlTextReaderImpl.Throw(Exception e) at System.Xml.XmlTextReaderImpl.ParseDocumentContent() at System.Xml.XmlTextReaderImpl.Read() at System.Xml.XmlTextReader.Read() at System.Xml.XmlReader.MoveToContent() at MonoDevelop.Components.Docking.DockFrame.LoadLayouts(XmlReader reader) at MonoDevelop.Components.Docking.DockFrame.LoadLayouts(String file) at MonoDevelop.Ide.Gui.DefaultWorkbench.CreateComponents() INFO [2015-08-25 15:16:16Z]: Updating Welcome Page from 'https://software.xamarin.com/Service/News'. INFO [2015-08-25 15:16:16Z]: Updating Prebuilt Apps from 'https://xamarin.com/PrebuiltApps.xml'. INFO [2015-08-25 15:16:16Z]: Updated license: Android Indie 9/8/2015 2:46:11 AM INFO [2015-08-25 15:16:16Z]: Prebuilt Apps image already up-to-date. INFO [2015-08-25 15:16:16Z]: Prebuilt Apps image already up-to-date. INFO [2015-08-25 15:16:17Z]: Prebuilt Apps already up-to-date. INFO [2015-08-25 15:16:17Z]: Prebuilt Apps updated. INFO [2015-08-25 15:16:17Z]: Welcome Page updated. INFO [2015-08-25 15:16:17Z]: CodeTemplateService: No user templates, reading default templates. INFO [2015-08-25 15:16:17Z]: Add-in loaded: MonoDevelop.ILAsmBinding INFO [2015-08-25 15:16:17Z]: Add-in loaded: MonoDevelop.Deployment.Linux INFO [2015-08-25 15:16:17Z]: Add-in loaded: MonoDevelop.CocosSharp.Templates INFO [2015-08-25 15:16:18Z]: Add-in loaded: MonoDevelop.VersionControl.Subversion INFO [2015-08-25 15:16:18Z]: Add-in loaded: MonoDevelop.VersionControl.Subversion.Windows ERROR [2015-08-25 15:16:18Z]: Xamarin Studio failed to start System.InvalidOperationException: Collection was modified; enumeration operation may not execute. at System.ThrowHelper.ThrowInvalidOperationException(ExceptionResource resource) at System.Collections.Generic.List1.Enumerator.MoveNextRare() at System.Collections.Generic.List1.Enumerator.MoveNext() at MonoDevelop.Ide.Gui.DefaultWorkbench.InitializeLayout(String name) at MonoDevelop.Ide.Gui.DefaultWorkbench.set_CurrentLayout(String value) at MonoDevelop.Ide.Gui.Workbench.Show(String workbenchMemento) at MonoDevelop.Ide.IdeApp.Initialize(IProgressMonitor monitor) at MonoDevelop.Ide.IdeStartup.Run(MonoDevelopOptions options)

I did delete GIT repository that I had, but I don't know if that is what is causing Xamarin to crash on startup without loading any projects. Could I remove somehow the subversion add-in without loading Xamarin Studio?

Thanks!

Best Answer

Answers

  • Perfect, thanks!

Sign In or Register to comment.