Newtonsoft.Json is not getting added to the packages

Vikram_BVikram_B USMember ✭✭

Hi I am trying to add Kidozen package in my Xamarin studio.

I am getting following error

Adding 'Newtonsoft.Json 6.0.8' to kidozen_TEST.Droid.
Could not install package 'Newtonsoft.Json 6.0.8'. You are trying to install this package into a project that targets 'MonoAndroid,Version=v5.0', but the package does not contain any assembly references or content files that are compatible with that framework. For more information, contact the package author.

Can Any one explain where I can change the MonoAndroid,Version=v5.0 in my Xamarin studio.How to fix this error.

Answers

  • rmaciasrmacias USBeta, University ✭✭✭✭✭

    Which version of Xamarin.Android are you running? Try updating to the latest version.

  • Vikram_BVikram_B USMember ✭✭

    I am using Xamarin studio 5.9

  • rmaciasrmacias USBeta, University ✭✭✭✭✭

    But which version of Xamarin.Android? It's in the about section. Click on "Show Details", it'll show you. In fact, you can copy and paste that info here. I'm guessing one of your components might be out of date. I was able to add the package just fine.

  • Vikram_BVikram_B USMember ✭✭

    Xamarin.Android
    Version: 5.1.4 (Trial Edition)
    Android SDK: D:\Softwares\Android\adt-bundle-windows-x86-20130219\adt-bundle-windows-x86-20130219\sdk
    Supported Android versions:
    2.3 (API level 10)
    4.0.3 (API level 15)
    4.1 (API level 16)
    4.2 (API level 17)
    4.3 (API level 18)
    4.4 (API level 19)
    4.4.87 (API level 20)
    5.0 (API level 21)
    Java SDK: C:\Program Files\Java\jdk1.7.0_67
    java version "1.7.0_67"
    Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
    Java HotSpot(TM) Client VM (build 24.65-b04, mixed mode, sharing)

  • Vikram_BVikram_B USMember ✭✭

    Hi Guys,

    I found the solution.You can add Json.NET package from the Nuget package that will allow you to use Newsoft.Json features .It works like charm for me.

Sign In or Register to comment.