WARNING: Android SDK Tools rev v24.3.4

CodyBCodyB USXamarin Team Xamurai
edited August 2015 in Xamarin.Android


Google has released a new version of Android SDK Tools (rev. 24.3.4). This version breaks the Xamarin.Android designer.

Update August 19: fix for Designer issue (Bug 33174) now available in the Stable channel

The fix for the designer Bug 33174 has now been released to the Stable channel:

If you still see Bug 33174 after updating, or if you find any additional bugs caused by Android SDK Tools (rev. 24.3.4), please file a bug report and add a comment back on this thread with the bug number. Thanks!

Known issues with latest Stable (listed above)

There are currently two known issues with the released builds. This post will be updated to reflect progress on these bugs, as updates are available

Private bug 33236 - On starting Xamarin Android Player with Xamarin Studio, IP address of Xamarin Android Player emulator displays in device configuration dropdown.

Private bug 33237 - Unable to start Xamarin Android Player emulator as it is displaying as an unsupported section in device list in VS.

Error Message

ERROR: java.lang.NoSuchMethodError: com.android.ide.common.rendering.api.HardwareConfig.<init>                  

Alternate workaround

If you do not want to upgrade yet, the below workaround is still valid. However, if you at any point want to upgrade to Android SDK Tools 24.3.4, then you will need to upgrade to the versions listed above.

Downgrade links



Downgrade steps

  1. Close ALL instances of Visual Studio and/or Xamarin Studio
  2. Locate the tools directory in the Android SDK path. One way to find the right directory is to open "Tools -> Open Android SDK Manager" in Xamarin Studio or "Tools -> Android -> Android SDK Manager" in Visual Studio. The tools subdirectory can be found within the "SDK Path" that is displayed at the top of the SDK Manager window.
  3. Delete the tools directory.
  4. Unzip the tools_r24.3.3*.zip file into the "SDK Path", creating a directory named "tools". Be careful not to create an extra outer "tools" directory when unzipping this file: the top-level "SDK path" should contain tools/android*, not tools/tools/android*.

Bugzilla Link


What to do if the workaround doesn't work

Please post a screenshot of your SDK tools window. This is available via the following means:

  • Xamarin Studio : Tools >Open Android SDK Manager

  • Visual Studio : Tools > Android > Android SDK Manager

A compliant Android SDK Manager will look similar to the following screenshot, where an update is available to 24.3.4, but not installed:



  • chrismorrischrismorris USMember
    edited August 2015

    Downgrade did not work for me. More details here:


    I literally installed Android SDK and Xamarin at 5 PM, didn't see this notice to use an older version.

    Also, your downgrade links are both for Mac OS X.

  • CodyBCodyB USXamarin Team Xamurai


    Thanks for the feedback. I will test a few scenarios to reproduce what you are seeing and will respond back shortly.

    Thanks again!

  • chrismorrischrismorris USMember

    After completely uninstalling Xamarin and Android Studio, I reinstalled Android studio and Xamarin, opened Xamarin to confirm the SDK file path, then before opening up a new project, I replaced the tools folder, closed Xamarin, re-opened it, and now the Main.axml loads correctly. Not sure if this helps.

  • Miguel.9535Miguel.9535 USMember

    Thanks CodyB now it's working

  • CasperSrensenCasperSrensen DKMember

    I had the same issue. Before realizing the downgrade revision was 24.3.3 (and not 24.2 as I first thought the problem was similar to this one) I followed the steps suggested by chrismorris above, which did solve the problem, however a simple downgrade might have solved it.


  • JeremyKolbJeremyKolb USMember ✭✭✭

    Luckily the designer is pretty minimal.

  • AdithyaRAdithyaR USMember

    Guys, SDK Tools version 24.3.3 is working fine as i can see the designer. Thanks for the workaround.

  • TousifRazaTousifRaza INMember ✭✭

    Thanx @CodyB , now the problem is solved.

  • TSchuckTSchuck USMember

    work's for the moment

  • Ram.4301Ram.4301 USMember

    Fantastic it worked....I have downloaded 24.3.3 and replaced TOOLS folder and ran the VS and it worked...Great Thank you

  • Thanks, replacing the tools folder works for me

  • JoeHJoeH USMember

    Thanks, downgrading works. Guess I decided to test out your product a couple days late, otherwise would not have got so frustrated because it didn't work off the bat. Good work getting the solution out so quick

  • AndreLeblancAndreLeblanc USMember ✭✭

    Work great for me. Thanks!

  • Silvia15Silvia15 AUMember

    Layouts back, works for me too. Thanks

  • MohamedFouadMohamedFouad USMember

    Thanks Now It's Work Fine :smile:

  • ozandozand USMember

    Version 3.11.837 is no more available for download?

  • CodyBCodyB USXamarin Team Xamurai


    The download link will take you to the latest version from our Xamarin Store, which includes the hotfix.


  • ozandozand USMember

    @CodyB thanks for quick reply but the latest version doesn't fix the issue for me (and the latest version is still the version 3.11.836 (ed5c750)).

  • CodyBCodyB USXamarin Team Xamurai


    From within your IDE are you able to check for Xamarin updates?

  • ozandozand USMember

    @CodyB update from within IDE worked fine (3.11.837 is now installed) and the designer is working now fine. Thanks

  • zzinzzin CAMember ✭✭

    Since I upgraded from 5.94 to 5.95, the xamarin android player emulator has been hanging, it says 'waiting for Nexus 4 to start' but it never starts. ive downgraded to 5.94 and it still did not make a difference. I need help asap.

  • YigitDikerYigitDiker TRMember

    My SDK screen in Picture.
    Error is "the layout could not be loaded: the operation failed due to an internal error: com.adroid.ide.common.rendering.api.HardwareConfig.(IILcom/android/resources/Density;FFLcom/android/resources/ScreenSize;Lcom/android/resorces/ScreenOrientation;Z)V."

    How i can solve this problem? Your suggestions do not solve the problem.

  • ryanoberleitnerryanoberleitner USUniversity ✭✭

    even after rolling back to 24.3.3, xamarin studio can't connect to the xamarin android player if i launch the player from xamarin studio. if i manually launch the player, i can connect to it by selecting the IP address of the player in xamarin studio.

  • zzinzzin CAMember ✭✭

    iv'e updated the sdk manager I cannot connect to the xamarin android player. please help asap.

  • ryanoberleitnerryanoberleitner USUniversity ✭✭

    launch xamarin android player manually, then select the player's ip address as the device you wish to connect to in xamarin studio.

  • zzinzzin CAMember ✭✭

    thank you @leankitryan :smile:

  • diiafdiiaf DEMember


    For those of you who use VS 2015 Enterprise (not sure if this will fix it on other versions):
    I had the same issue. Downgrading and only installing this update didn't work for me.

    My Solution was, to install the update, create a new Blanc-App-Project in Xamarin Studio(not in VS), and manually clicking
    threw the whole project and update things like "Xamarin.Forms" by rightclick->update.
    Make sure that there is a note which tells you if it is updateable (e.g. "Xamarin.Forms ( update)".
    Restarting Xamarin Studio and Visual Studio after this steps solved my problem.
    (btw im running windows 10, not sure if this is relevant).

    Good luck!

  • AnthonyRamirezAnthonyRamirez USUniversity ✭✭✭

    Hi @CodyB!

    Thanks for the post :)

    I am still having issues with the Debug button in VS and Unsupported Devices. (It's really slowing me down)

    I reverted my Android SDK as per above and below is my Android SDK screenshot

    Do you have any information or workaround for:
    Private bug 33237 - Unable to start Xamarin Android Player emulator as it is displaying as an unsupported section in device list in VS.


  • LeandroInacioLeandroInacio BRMember


    after updating the Xamarin, Android Designer is not displaying the custom layout.
    Before the upgrade, the layout was displayed normally.
    Attached my layout files.

  • kojankojan ILMember

    non of the above is working, still have the same issue ! starting to hate this xamarin thing .
    since i installed it its fixing issues that are not related to my code.

  • wootwoot USMember

    I'm also unable to use Xamarin Android Player from VS unfortunately. I tried doing the downgrade to the previous tools and still no dice. Had to switch to VS Android Emulator (which has come a long way) but would still like to be able to use XAP again at some point.

  • MikePeretzMikePeretz USMember

    How do you get the latest version, when I run the install it tells me I have the latest version (but I don't).

  • RyanPalmer.0677RyanPalmer.0677 USMember ✭✭
    edited August 2015

    Filed a new bug: Adding a switch to a layout causes the designer to throw an exception if targeting 5.1 with SDK 24.3.4. https://bugzilla.xamarin.com/show_bug.cgi?id=33389

  • ChuckHedleyChuckHedley USMember

    This is happening to me as well. MacOS, Xamarin Studio. After this update, I was able to open/edit my layout, but upon then running my app, I'm left with this same "Starting _____..." issue. Android Player starts. I can unlock the screen. I can even run the previous installation of my app. But it's as if Android Player is no longer notifying Xamarin Studio that it's loaded so that Studio can progress to the next step of installing and running my app. Someone, please help.

  • ChuckHedleyChuckHedley USMember

    Trying the suggestion of @leankitryan to run Android Player manually and then selecting its IP address within Xamarin Studio is also failing for me. "Deployment failed. Architecture not supported." What is going on?? Someone needs to get this world put back together quickly. Or explain to us how we're all doing this the wrong way, and what the correct way is. I've gone a couple cycles of replacing the tools folder, updating SDK Tools through the SDK Manager, installing the latest build of Xamarin, rebooting, on and on and on. It's possible that I've created some disconnection of sorts that is now resulting in "Architecture not supported" since I don't see anyone else reporting that. Any help at all will be greatly appreciated.

  • UddhaoPachrneUddhaoPachrne INMember ✭✭

    @CodyB thanks.
    First replace tools folder and then installed 3.11.837. Now designer is working fine.

  • PeterB2015PeterB2015 CAMember

    @twoo I'm experiencing the same issue. I've tried various things including reverting back to older SDK and Xamarin Android Player will still not launch properly (it's listed in Unsupported Devices)

  • wootwoot USMember

    @PeterB2015 - Same XAP VM's were always in unsupported devices. Tried all the suggestions and still no dice. I'd recommend just using regular devices or VS Android Emu until they get a new patch out.

  • himanshu.6904himanshu.6904 USMember

    I am using Visual studio 2015 and android sdk version 24.3.4, every time I try to open the Layout page it gives me an error as show in the attached snap shot. I had tried everything from reinstalling the package to downgrade the sdk to 24.3.3 Moreover when I downgrade the sdk and try to create a new project it gives object reference null error.

  • himanshu.6904himanshu.6904 USMember

    Thanks Xamarin Team your solution really helped.

This discussion has been closed.