Why do new assets added not get updated?

I had some Icons for my Xamarin forms project which are in the IOS project resources folder, I wanted to replace them so initially I dragged the files on to the folder in the solution panel but it said there was already a file with that name. I deleted the files from the solution pane and chose delete rather than just remove and then tried re-adding them. The problem is now the files I have updated by removing and replacing have little red x's next to them and when I run the app it still uses the old Icons.

I was a little frustrated so I copied the files over to a temporary location and deleted the whole resources folder in the Solution panel, added it again from the solution panel. After that I got all my icons and dragged them on to the new Resources folder in the Solution panel and it did nothing. It turns out I have to drag them in batches because they only work about 10 at a time. after adding all my resources again all the files have red crosses and the app still builds with the old resources.

TL;DR : App still builds with old resources after replacing them.

Sign In or Register to comment.