Alpha Release: Xamarin.iOS 8.10.4, Cycle 5 – Service Release 3

BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
edited August 2015 in Xamarin.iOS

This thread has now been closed to direct all further updates about this service release onto the new Beta release thread:

http://forums.xamarin.com/discussion/47347/beta-release-xamarin-ios-8-10-4-cycle-5-service-release-3/p1


Visual Studio Extension

  • Xamarin.VisualStudio_3.11.816.msi (cefca47)

Mac

  • monotouch-8.10.4.27.pkg (7cf6633)

Reason for release: Additional bug fixes for the "Cycle 5" Stable Release on April 29 and the previous Cycle 5 Service Releases. (See the release blog for a short description of "Cycles" and "Service Releases.")

Release notes: http://developer.xamarin.com/releases/ios/xamarin.ios_8/xamarin.ios_8.10/#Xamarin.iOS_8.10.4

Date published: See https://releases.xamarin.com/.

NOTE: Alpha versions have not yet completed the full suite of tests by the Xamarin QA team. That said, customer reports of any regressions (or bugs that are incorrectly marked fixed) are still much appreciated, even if the problem would have eventually been caught during the full QA testing process.

Previous versions, downgrading

You can downgrade back to the current Stable version by switching updater channels.

Older versions (from before April 29)

If needed, you can downgrade back to older versions (from before April 29) by manually reinstalling each old package. See the "Previous versions, downgrading" section on the April 29 Stable release thread for the older downgrade links.

Guidelines for this thread

  1. This first post will be updated regularly.

  2. Hopefully this thread will help answer "what might break if I update to this release?"

  3. If you find a new problem that is specific to this version, please file a bug report.

  4. Please discuss older bugs that are unchanged in this release compared to the previous Stable version in Bugzilla instead.

  5. Of course for questions and discussions about topics other than bugs, feel free start new forum threads.

Remaining known issues from the April 29 Stable Channel release, with more common or severe issues near the top

  • Non-public Bug 30481, Bug 29557 - [Mono] [Android] [iOS] SqlConnection.GetSchema() fails with "SourceTable is required to be a non-empty string". (A fix for this issue is planned for the upcoming "Service Release 3.")

  • Bug 29745 - [iOS] Error due to duplicate symbols during native compilation for device: "duplicate symbol _monoeg_g_array_new" (and many similar messages). Workarounds: disable profiling under "Project Properties -> iOS Build", or if your app uses the -all_load linker flag (via either gcc_flags or LinkerFlags) try removing it.

  • Bug 31379, Bug 31560 - [iOS] Enabling the linker when the app references PCL projects that include "duplicate" System.Threading.Tasks references (for example when using the "Microsoft.Net.Http" NuGet in a .NET 4.0 PCL) causes "Could not load file or assembly 'System.Threading.Tasks'" on the simulator. This bug has in fact existed since the original April 29 release of Cycle 5, but until Service Release 2 it had been obscured by the closely related Bug 29211. The bug only affects simulator builds and has fairly easy workarounds, so it is minor in severity. Workarounds: disable the linker in the iPhoneSimulator configurations or add -linkskip=System.Threading.Tasks under "project options -> iOS Build -> Additional mtouch arguments".

Remaining known issues from Cycle 5 – Service Release 2

  • Bug 31423 - [XamarinVS] [Android] [iOS] Locked .dll files: "Could not copy "... PortableClassLibrary1.dll" to "bin\Debug\PortableClassLibrary1.dll". Exceeded retry count of 10. Failed." This is a different problem than Bug 26841 because it affects .dll files rather than .dll.mdb files. It appears to be less common than Bug 26841. The results to date suggest that it is a bug in Visual Studio itself rather than in the Xamarin extensions. For example, it appears to be possible to hit the problem using a Windows Phone project, with no Xamarin involvement at all. The recent changes to the Xamarin "Clean project" process to properly remove stale files might have caused this to become easier to hit with Xamarin projects. In any case, it is still under investigation.

Remaining known issues from before the April 29 Stable Channel release

(For issues that might behave differently for some customers after updating to this new release, or that might be difficult to find via Bugzilla.)

  • Bug 28027 - [XamarinVS] [iOS] The debugger sometimes fails to connect properly after the app launches. This means breakpoints will not be hit during that launch of the app and the "Output -> Debug" window will be blank. Repeating the steps of (a) stopping the debugger and (b) relaunching the app will eventually lead to a successful connection. This problem has existed since at least XamarinVS 3.9.483, but some recent reports suggest that it has become more common for certain users recently. The problem might be caused by a race condition. Based on that guess, the recent releases might have changed some timings and increased the probability of hitting the issue on a wider range of system configurations. The bug is under active investigation.

  • Bug 29897 - [XamarinVS] [iOS] Breakpoints sometimes don't work when debugging on iOS device. Based on the observed behavior of this problem, it appears to have the same underlying cause as Bug 28027.

New known issues

  • Non-public Bug 32298 - [Xamarin Studio] [iOS] Applications with . dot/period characters in the assembly name crash when launching in the Release configuration on iPhoneSimulator. The simulator log shows "Could not find the assembly MyApplication.exe", when the name of the assembly is in fact "My.Application.exe".

EDIT July 24: Update version numbers for new Alpha builds. Remove now fixed iOS bug 31893. Add Mac-only iOS Bug 32298.

This discussion has been closed.