Error "authentication or decryption has failed." now in 4.7.5

GerryHighGerryHigh USBeta ✭✭✭

Getting this error on code that used to work on a HttpWebRequest over https. Ironically I can run the same shared code on iOS and it works. However, on Android it fails. I'm wondering if there has been a regression sometime in the build?

Gerry

InnerException {System.IO.IOException: The authentication or decryption has failed. ---> System.NullReferenceException: Object reference not set to an instance of an object at Mono.Security.Protocol.Tls.CipherSuite.createEncryptionCipher () [0x00000] in :0 at Mono.Security.Protocol.Tls.CipherSuite.InitializeCipher () [0x00000] in :0 at Mono.Security.Protocol.Tls.SslClientStream.OnNegotiateHandshakeCallback (IAsyncResult asyncResult) [0x00000] in :0 at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in :0 --- End of inner exception stack trace --- at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallback (IAsyncResult asyncResult) [0x00000] in :0 } System.IO.IOException

Posts

  • ChrisHonselaarChrisHonselaar NLBeta ✭✭✭

    Might be better to post this in the beta forum? Also make sure to file a bug report.

  • GerryHighGerryHigh USBeta ✭✭✭

    Perhaps. Most people that get the "The authentication or decryption has failed." error also then get a certificate error. However, in this case the stack trace is different those cases from this one (in my case I see "Object reference not set to an instance of an object at Mono.Security.Protocol.Tls.CipherSuite.createEncryptionCipher () ").

  • GerryHighGerryHigh USBeta ✭✭✭

    I filed a bug report on this.

Sign In or Register to comment.