Xamarin.Forms 1.4.3 Released

124»

Posts

  • TheRealJasonSmithTheRealJasonSmith USXamarin Team Xamurai

    Tekton looks like someone in the upgrade fuckled your sln or csproj files. We don't (unfortunately) control what nuget does there.

  • TheRealJasonSmithTheRealJasonSmith USXamarin Team Xamurai

    @DirkWeltz I obviously believe your issue is real, I just have NO idea how to cause it :/

  • mserougi_clmserougi_cl EGMember
    edited July 2015

    I noticed an issue with UI orientation, and it only applies to the iPhone 6+ as far as I've tested, no issues on the iPad. My app is set to portrait only, but if I rotate the device to landscape then launch the app, the UI is completely messed up in one of the views. Oddly enough, the first page that shows is fine, it's a basic screen with a button and some images. Now the second page that I push after is the problem, it's an AbsoluteLayout with a Grid, but the entire UI is overflowing everywhere. The orientation is locked so if I rotate the device, nothing changes. Now if I launch the app with the device in portrait, all pages are fine. I tested this against 1.4.2 and the issue does not reproduce.

    Just tested this against 1.4.3.6376, no longer an issue.

  • LesterMeeksLesterMeeks USMember ✭✭
    edited July 2015

    @TheRealJasonSmith - Any eyes on the grouped, variable cell height, observed list modified at runtime issue that leaves my cells blank? Posted a XS solution (on page 2) that reproduces on both android and iOS on page two? Works kinda in 1.4.2 (empty headers sometimes in scrolling), but in 1.4.3 it only produces empty cells.

  • TheRealJasonSmithTheRealJasonSmith USXamarin Team Xamurai

    @LesterMeeks I will poke at it

  • RogerHardimanRogerHardiman GBMember ✭✭

    I've just posted bugzilla 31816 which covers the new iOS list view bug I found where the gap between Header and the Contents keeps increasing after IsVisibile() is called. I'd mentioned it in this thread before but now have a bugzilla filed with sample code that reproduces the issue.

    This bug was not in 1.4.2. Was new when I upgraded to 1.4.3 and occurs on iOS Simulator (4s running 8.4) as well as on real device iPhone 6 (iOS 8.4)

  • TomStandaert.0575TomStandaert.0575 BEMember ✭✭

    @ChrisMcBride Hey Chris, there is a way around it, but you need visual studio. I discussed it here

    https://forums.xamarin.com/discussion/44772/xamarin-forms-maps-dependencies-problem#latest

  • TheRealJasonSmithTheRealJasonSmith USXamarin Team Xamurai

    @RogerHardiman I found the issue.

    The issue stems from the way that iOS attempts to handle alignment of the rest of the ListView to the Header. The facts are as follows:

    1) The bug is reproducible as far back as 1.4.0 where this code was first introduced.

    2) The header created in this example measures out to 20.5dp tall. (It's a label and labels can have "subpixel" sizes)

    3) The UITableView has some kind of alignment mechanism for when the HeaderView is not a dp unit height. This causes it to pad out some extra space.

    There seems to be some kind of bug in the way the UITableView pads out these sizes such that when you simply toggle the visibility of the tableview back and forth over and over the padding gets added over and over causing your header to slowly grow. Well not really your header so much as spacing between the header and the UITableView contents.

    The fix? Math.Ceiling! Yup, so long as we handle this alignment ourselves rather than let iOS do it, the bug doesn't occur.

    Thanks for the report :)

  • RodyLagerwaardRodyLagerwaard USMember ✭✭

    @TheRealJasonSmith @LesterMeeks I have a simular issue, a observable collection bindend to a listview (not grouped). Cells have a variable height as well. When I start scrolling some (randomly) cells appear to be not visible.

  • RaphaelSchindlerRaphaelSchindler USMember ✭✭✭

    @TheRealJasonSmith I added some additional information to this bug https://bugzilla.xamarin.com/show_bug.cgi?id=23079

  • TonyDTonyD USMember ✭✭✭

    Well, I now have a broken app on the app store :(

    A bunch of UI elements are disappearing when submitted to the app store on iPhone 6/6S

    It works on the Debug and Release simulators, it works on my real iPhone 6 with the Debug certificate, and it works on testcloud.

    When I deploy to the app store, a bunch of form elements are missing. I am attaching a screenshot of the difference. This happens on nearly every page - random UI elements have gone missing.

    My suspicion is that there is an issue with linking the XF assembly though I could be wrong since it works on the simulator. @TheRealJasonSmith - any ideas?

  • ChaseFlorellChaseFlorell CAInsider, University mod

    @TonyD, it might be a Linker issue. Unfortunately I'm not at my desk right now, so I can't dig up the right way to fix it :neutral: sry.

  • TheRealJasonSmithTheRealJasonSmith USXamarin Team Xamurai

    @TonyD if you are binding data and the linker is enabled and the only way your bound properties are accessed is through the bindings, the linker will gobble them up.

  • ChaseFlorellChaseFlorell CAInsider, University mod
  • TonyDTonyD USMember ✭✭✭

    @TheRealJasonSmith , @ChaseFlorell , @KenPespisa - I debugged the way you recommended.

    Turning off linking entirely had no effect (except bloat the total app size).

    However, turning off LLVM "fixed" the issue. I'm not sure if I'm hitting some weird known bug there.

    Again, the issue only happens on iPhone 6 and beyond (possibly iPhone 5S but I don't have one). It doesn't happen on iPhone 4S.

  • TheRealJasonSmithTheRealJasonSmith USXamarin Team Xamurai

    @TonyD the fact that turning llvm off had any impact on your app at all is deeply upsetting... Will try to find the right person today.

  • MichaelRumplerMichaelRumpler ATMember ✭✭✭✭✭

    The sample project for bug 32182 uses XF 1.4.3.6376. In that project bug 28242 pops up again. It was set to VERIFIED FIXED in version 1.4.3-pre1.

  • TheRealJasonSmithTheRealJasonSmith USXamarin Team Xamurai

    Yes we see a regression on 28242 on iOS, it's being worked on.

  • MichaelRumplerMichaelRumpler ATMember ✭✭✭✭✭

    I get the same behavior on all five platforms, not just iOS.
    Appearing is raised for all subpages when the CarouselPage gets displayed. It is also raised for the invisible pages. When you switch pages, nothing is raised. Disappearing is never raised (maybe when the whole CarouselPage is poped, I didn't test that).

  • TheRealJasonSmithTheRealJasonSmith USXamarin Team Xamurai

    it will be raised when it is popped yes

  • MichaelRumplerMichaelRumpler ATMember ✭✭✭✭✭

    Sorry, I don't want to be picky, but I'm not sure you understood what I was trying to say.

    I would expect, when my CarouselPage contains PageA and PageB and the user switches from PageA to PageB, that PageA raises Disappearing and PageB raises Appearing. But this is not the case on any platform.

  • TheRealJasonSmithTheRealJasonSmith USXamarin Team Xamurai

    Oh yeah no that is not the behavior that happens or will happen (mostly because this is not what the native stuff does).

  • MichaelRumplerMichaelRumpler ATMember ✭✭✭✭✭

    Aha. Strange, but thanks for letting me know.

    Then I'll try to do a workaround with the CurrentPageChanged event of the parent MultiPage.

  • I did a fresh installation of xamarin on my fresh desktop last week, I created a new project And it couldn't compile. I got a whole lot of exception relating to android support version 4 library, it not existing. Anybody with a help on this issue

  • JKayJKay USMember ✭✭✭

    @PeterAkakpo.7999 Have you made sure your android SDK is up to date? Including the Extras?

  • RogerSchmidlinRogerSchmidlin CHUniversity ✭✭✭

    @PeterAkakpo.7999 This can happen, when Xamarin gets aborted when updating. Sounds like your zip file is corrupted. I deleted it and loaded it again. Just be patient and let Xamarin finish its business, and that might take a while sometimes :smile: The error message usually tells you quite well what to do in this case. And it also shows you the path of the zip file that is corrupted. I hope that helps :smile: -> remove zip file (android support library), download it again with sdk manager and let xamarin do its business.

  • ChrisMcBrideChrisMcBride USMember ✭✭

    As I mentioned earlier I was getting an error with java.exe as there were too many references (because googleplay was split up and loading everything)
    Someone pointed out that I could resolve the issue by linking to v22 of googleplay. I did that, things seemed to work, but then I couldn't build the release version, unless I turned linking off. I run into this issue:https://forums.xamarin.com/discussion/41900/linking-issue
    Turning linking off is not really an option.
    Once again I'm forced to downgrade to the previous version of xamarin.

  • rmarinhormarinho PTMember, Insider, Beta Xamurai

    Hey guys, make sure you have the latest Android SDK updates, and also GooglePlayServices also installed via Android SDK Manager (is in the bottom)

  • What target/compile version of Android is your app set to? It should be "Use Latest Platform" or at least API Level 21. (Note this is not the same as the minimum that your app supports.)

    I have tablet with Android 4.0.3 (API 15).
    Can I use this tablet for test application in Debug Mode?
    In API15 I have the same exception: System.MissingMethodException

124»
Sign In or Register to comment.