Xamarain does not appear in Visual Studio Community 2013

Harald-RenFlaschHarald-RenFlasch Harald-René FlaschATMember

Have installed Xamarin on two machines:

Machine #1:
Windows 7 Ultimate, 64 bit
Real machine
Xamarin does not appear under Tools menu in Visual Studio Community 2013
Xamarin works fine in Visual Studio Ultimate 2012

Machine #2:
Windows 8.1, 64 bit
Virtual machine (VMware)
Xamarin works fine in Visual Studio Community 2013

Of course the license (trial) is set to the active machine where I am evaluating Xamarin at the moment. What I have to do that Xamarin will be integrated into Visual Studio Community 2013 on my Windows 7 machine? Later, I'll use Windows 10 on my real machine. But for now it is a "must have" to be able to use Xamarin within Visual Studio Community 2013 on my Windows 7 machine in order to be able to convince the CEO about Xamarin (as technician/software developer I am already convinced that Xamarin is the right choice).

Thanks in advance for putting me into the right direction :)

--hfrmobile (trial: 20 days left)

Best Answer

Answers

  • VictorGarciaAprea.9996VictorGarciaAprea.9996 Victor Garcia Aprea USXamarin Team Xamurai

    Hi Harald-René,

    There is a bug in the Xamarin Universal installer which prevents it to install to VS Community editions. We have fixed it but a new build of the installer is not public yet.

    In the meantime, this is how you can fix it:

    1) Browse to xamarin.com and sign in
    2) Click on the upper-right corner, on your name to display a menu
    3) Click on "Dashboard"
    4) Go to the left-column and click on "Downloads"
    5) Now you can select to download just the Xamarin for Visual Studio MSI (which works with VS Community)

    I'm attaching a screenshot to help the guessing game.

    Let me know if this helps

    thanks,

  • VictorGarciaAprea.9996VictorGarciaAprea.9996 Victor Garcia Aprea USXamarin Team Xamurai

    Looks like the attachment did't work, here it goes again.

  • Harald-RenFlaschHarald-RenFlasch Harald-René Flasch ATMember

    Thank you for your response, but it looks different for me - see screenshot.

    Only see Download for Xamarin Studio, even when I click "Show all versions". The odd thing is, that int integrated into VS Community on the virtual machine (Windows 8.1) but not integrated on my real machine (Windows 7) machine.

  • VictorGarciaAprea.9996VictorGarciaAprea.9996 Victor Garcia Aprea USXamarin Team Xamurai

    Mmm... I'm not sure why you are not getting all the available downloads... why type of subscription do you have? I'm using a Business one.

    Which installer did you run on each case? The fact that it installed in one and did't in the other tells me that you may have run different installers.

    thanks

  • Harald-RenFlaschHarald-RenFlasch Harald-René Flasch ATMember

    As far I can remember I used https://store.xamarin.com/account/my/subscription/installer?os=win

    Currently I am still evaluating Xamarin and so I am using "Evaluation license" (first installed on 2015-05-15).

  • Harald-RenFlaschHarald-RenFlasch Harald-René Flasch ATMember

    @VGA:

    Yep, that's the Universal installer and it is currently not installing to VS 2013 Community edition. A fix is on its way.

    But the odd thing is, that it has integrated into Visual Studio Community 2013 on my virtual machine (Windows 8.1) but it didn't integrate into Visual Studio Community 2013 on my real machine (Windows 7).

    Since I am currently evaluating Xamarin on my virtual machine I'll wait for the official fix. Thank you anyway for the offer!

  • Harald-RenFlaschHarald-RenFlasch Harald-René Flasch ATMember

    Btw, did a re-install on my Windows 7 machine and now Xamarin is visible to Visual Studio Community 2013 too

Sign In or Register to comment.