Visual Studio crashes when starting debug for iOS (Simulator / Device)

Paul_RoyPaul_Roy Paul RoyFRMember ✭✭

Hi everyone.

Lately I had a huge problem with Xamarin iOS.
First step, Visual studio crashed when stopping debug on a breakpoint during the execution of the app (simulator).

Now Visual Studio crash everytime I try to debug.
I tried to reboot (Mac / PC), restart VS, clean (or delete files on the PC), restart the build host, re-pair the build host, etc.
Nothing seems to work.

I had the problem yesterday, and suddenly it worked again, I can't tell what changed. If I remember well the first step was the same (crash when stopping debug on a breakpoint).

The build host only says « Error: Failed to send response to Visual Studio » and « Exception: Exception type: System.IO.IOException Write Failure (…) »

On the event log of windows, I have a lot of errors, two are worth noticing.
First is an Error on devenv.exe, ArgumentOutOfRangeException.
Second is an Error, precisely a CommunicationException / IOException / CommunicationException / PipeException (communication pipe was closed if I translate it)

This is crucial and already cost me nearly twice half a journey. Please, Xamarin, help me because this is currently blocking all my devs on iOS. This is a huge stability problem…

Don't hesitate to contact me to test things up.

Technical informations : Visual Studio Ultimate 2013 update 4
Xamarin 3.11.590.0
Xamarin.iOS : 8.10.1.0

Posts

  • Paul_RoyPaul_Roy Paul Roy FRMember ✭✭
    edited June 2015

    And here it goes again, it resolved itself late last afternoon, and once again I'm stuck on this. Once again, I stopped the debugger when I was on a breakpoint (old habits die hard), visual studio crashed and I can no longer debug my application.

    Please Xamarin, provide some support for this or try to reproduce on your side, I've had various debugger problems on almost all releases and this is really, like really wasting my time and blocking me each time.

    EDIT: After this, Visual studio crashes EVERYTIME I try to debug, even for the Android app. I'm just completely stuck.

  • Paul_RoyPaul_Roy Paul Roy FRMember ✭✭
    edited June 2015

    Still not working…

    I have an even more disturbing test case. Loading VS and opening the project causes no problem. Loading VS directly on the project causes no problem. However, loading VS with another project, THEN loading my project also crashes all the time. The other projects are not affected by the bug, I can debug the application, this bug is only happening on my main project.

    Could Xamarin have corrupted the project file in some way ?!

    EDIT: on the configuration manager, I unchecked a project, saved, re-checked the project, saved, and now I can launch on my WP emulator… what the…?

  • Paul_RoyPaul_Roy Paul Roy FRMember ✭✭

    For those who encounter the problem, running:

    devenv.exe /resetsettings
    deven.exe /resetuserdata

    Seem to fix it, at least for now…

Sign In or Register to comment.