Setting Breakpoints in 4.0.8

fluentfluent USMember

I'm sure i'm being a complete noob but for the life of me I cannot get Xamarin studio to set a breakpoint. All the docs online state that a simple click to the left of the line number will do it but it doesn't seem to work. Right clicking occasionally gives me a pop up menu (roughly 1 out of every 10 clicks) but all the breakpoint options are greyed out.

Someone put me out of my misery. I'm on the indie version if that makes any difference.

Posts

  • ChrisHardyChrisHardy GBForum Administrator, Xamarin Team Xamurai

    Does restarting Xamarin Studio resolve this issue?

  • RossGardnerRossGardner GBMember

    Restarting Xamarin Studio made no difference but a complete reboot seems to have done the trick.

  • RogisterAlainRogisterAlain BEBeta ✭✭✭

    i Have the same problem with this version.

    Please a issue !!!

  • PaulSegeristPaulSegerist USMember

    I have the same problem. Can anyone from Xamarin help me please? My version is 4.0.8 (build 2).

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    I fixed this yesterday in git master. It was caused by a mutex try-lock timeout being too small.

    I ended up just removing the mutex locking altogether because it was pointless.

  • RynoBurgerRynoBurger USUniversity ✭✭

    This is also an issue for me. How can we get the latest version, do you have to switch to the Beta channel when checking for updates?

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    It's not yet released to the public, but it should be in the beta channel later this week (I suspect).

  • RynoBurgerRynoBurger USUniversity ✭✭

    Great, thanks!

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Hopefully it'll be going out to Beta today or tomorrow

Sign In or Register to comment.