Forum Xamarin.iOS


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Apple Watch beta build does not install from Testflight

GeorgiKolevGeorgiKolev USMember
edited June 2015 in Xamarin.iOS


I have created Apple Watch extension for existing application. Uploaded it to TestFlight, turned on internal testing and added testers. But only the main application is installed on the phone (nothing happens on the watch) and there is no option on the TestFlight app to install it. Also there is no indication that the app has watch support.

If I unpair the watch and then pair it, then I can see that the application starts to install on the watch and then fails with Application Verification Failed error.

This is the complete error from iPhone Console logs:

: failed to install WatchKit application, error: (Error Domain=LaunchServicesError Code=0 "The operation couldn’t be completed. (LaunchServicesError error 0.)" UserInfo=0x1756ae70 {Error=ApplicationVerificationFailed, ErrorDetail=-402620395, ErrorDescription=Failed to verify code signature of MIExecutableBundle : path = identifier = com.prehensilesoftware.operaddsv2.watchkitapp type = 4 : 0xe8008015 (Signer did not match any installed provisioning profile)})
: (Note ) WatchKit: application (com.prehensilesoftware.operaddsv2.watchkitapp), install status: 8, message: application install failed: Application Verification Failed

Additional info:

  • the watch extension and watch app bundle id's are in the correct format: [main-app-id].watchkitapp and [main-app-id].watchextension
  • works locally when using Ad-Hoc distribution profiles
  • there are no validation errors when submitting to iTunes, or when using codesign tool on the mac
  • the distribution profile on the main application has push notifications enabled, while the apple watch's distribution profiles doesn't (no other options are enabled also)
  • I'm submitting to TestFlight with separate App Store distribution profiles for every project (iOS app, Watch Kit App, Watch Kit Extension)
  • the iOS application is using files from Watch Kit extension (via links)
  • the Apple Watch projects were started before the release of the Watch (when watchkit sdk was in beta I think)
  • The steps to publish to iTunes are: rebuild solution in Xamarin Studio on Mac; use Archive option on the iOS application; locate the archive and manually remove the iTunesMetadata.plist; validate and publish the archive via XCode

I'm stuck from 3 days on this issue, will greatly appreciate any feedback (nothing from google helps).

Best Answer


  • GeorgiKolevGeorgiKolev USMember
    edited June 2015

    Resolved.. The issue turned out to be the one described in this post:

    In the archived package: Products/Applications/[AppName] package/Plugins/[ExtensionName]/[WatchAppName] package/Info.plist had two entries for UIDeviceFamily > 1 and 4. 1 is for iPhone, 4 is Watch. After I removed the entry for the iPhone the problem disappeared.

    I created new application and the issue persists there. If this setting is automatically added by Xamarin Studio, it should be fixed ASAP.

    The build environments where: Xamarin Studio 5.9.1, Xcode 6.2

  • @GeorgiKolev, were you able to submit your build to app store? I have same? issue -- app uploads to app store fine, but won't install watch app via TestFlight. I tried doing the following:

    • Do normal App Store build
    • Build->Archive for Publishing
    • From command line, "open Products/Applications/" and remove the "1" entry in UIDeviceFamily array
    • Close file
    • Go back to Xamarin Studio and click "Sign and Distribute"

    But I get error about invalid signing when I then upload via Loader. I do not see error if I skip the manual Info.plist edit. So editing the file manually is causing issue.

    FYI, with version of build that has the double entry in UIDeviceFamily (1 & 4 devices), I see this in device log:

    EXITING!!! updateGizmoApplicationsWithCompletion error - pluginProxy == nil for: file:///private/var/mobile/Containers/Bundle/Application/CE9A08AF-2A27-4914-BA83-4B92E1DA6AD9/

    Google does not find anything for this error (with my app info removed).

    On the phone, the phone version installs/runs OK and the "Apple Watch" app on phone shows my watch app, but it says "Install from TestFlight app..."

  • GeorgiKolevGeorgiKolev USMember
    edited June 2015

    Sorry for late reply. But, yes, as you found out:
    the necessary additional steps are:

    • remove iTunesMetadata.plist from the archive
    • remove "1" as entry for UIDeviceFamily in watch app info.plist in the archive
    • submit the archive through xCode (not loader)
  • No worries. I was just so glad you had documented the problem and solution. Thank you!

  • DeanCleaverDeanCleaver USMember ✭✭✭

    Is there a similar solution for AdHoc deployment? I am having the same error occur.

  • GeorgiKolevGeorgiKolev USMember

    You can not deploy to iTunes (TestFlight) AdHoc build as far as I know.

  • While the Bugzilla thread says fixed, it is not until Xamarin.iOS 8.12. Why couldn't this get in the Xamarin.iOS that was released to Beta this week? Jeez.

  • PhilipSharpPhilipSharp CNMember ✭✭

    Same problem (it seems no way to avoid the problems caused by xamarin.ios).

    Right now the version is Xamarin.ios., when 8.12?

    • You wait too long to wait 64bit support
    • You wait too long to wait the components used to support 64bit
    • Wait too long for Apple watch support (now waiting WatchOS2 support)
    • Now they tools are there, but you will find it's very tough to debug ...
    • Ok, hard work, they publish ..., now you find problems

    All caused by Xamarin.

  • PhilipSharpPhilipSharp CNMember ✭✭
    edited July 2015

    Same problems (it seems no way to avoid the problems caused by xamarin.ios).

    Right now the version is Xamarin.ios., when 8.12?

    • You waited too long for 64bit support
    • You waited too long for the components you used to support 64bit
    • You waited too long for Apple watch support (now you are waiting for WatchOS2 support, iOS9 support)
    • Now the tools are there, but you will find it's very hard to debug ...
    • Ok, you worked hard, then to publish ..., now you find problems (manually fixed them)
    • Seems version 8.12 will fix it, waiting ...
    • But all xamarin apps are crashing on iOS9 beta, when Xamarin can be ready?

    All caused by Xamarin.

  • AlexWhiteAlexWhite GBMember ✭✭✭

    Xamarin can only be responsible for the things they control, they don't control what Apple does in beta's, and Apple have a habit of changing fundamental things at the last minute. I have used Xamarin tools for 3+ years and whilst there is always room for improvement I think they do a really good job, I am sure they have teams working on the critical stuff, but like everything in development sometimes the seemly simple things can open a can of worms.

    End of the day keeping the developers like us happy is what pays them money so it will be at the top of their list of priorities to keep us happy.

Sign In or Register to comment.