Can't debug on real device from Visual Studio

I have Xamarin Visual Studio 3.11.458.0 and Xamarin.Android 5.1.1.0. I created a brand new project in Visual Studio but when I try to debug on real device (Galaxy S2, 4.0.3) the app gets deployed but I get Couldn't connect to logcat, GetProcessId returned: 0

If I deploy to an emulator or if I deploy from Xamarin.Studio I can debug the app normally. Also, debugging works for one of the projects I have and for Tasky sample app. I tried unchecking "Use Fast Deployment" but it didn't help.

The output of the device debug log is attached.

Is this a known bug or is there any workaround for this issue?

Best Answer

Answers

  • batmacibatmaci DEMember ✭✭✭✭✭

    Did you find a solution for this? I am having similar issue. thanks

  • I'm create an application in Xamarin and i'm always debug my apps in real device (Samsung_galaxy_Mega) and my apps always worked.But now if i debug the app in the real device it's don't work application is oppening but don't work only white screen or black. What happens? and how i can solve the problem?

  • GiorgiGiorgi USMember ✭✭
    Accepted Answer

    Fixed with latest update.

Sign In or Register to comment.