Forum Xamarin.iOS

No valid iPhone code signing keys found in keychain error

PerdeFlonPerdeFlon SEMember

I get this error when trying to build the HelloWorld_iPhone app using Xamarin Studios. I do have a valid certificate gotten from our Company admin. I can build and run on a simulator a corresponding simple app using Xcode only.
Is there any manual configuration in XS needed so that XS knows where to find my certificate?



  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai
    edited May 2013

    @peer754, Do you have a provisioning profile from Apple to sign an app for a device?
    This is different than a license for Xamarin Studio.

  • PerdeFlonPerdeFlon SEMember

    Yes I have provisioning profile and also a valid license for Xamarin. Do you mean I'll need another signing lic for Xamarin?

  • PerdeFlonPerdeFlon SEMember

    Hi again,

    It’s working now and it didn’t have anything to do with the Xamarin license.
    I am totally new to both app development and also to the Mac world as you probably can tell ;)

    The missing bit in this puzzle was for me to connect my certificate to Xcode through the organizer whick I didn’t know.
    However, as I’ve been informed, running on the simulator will not normally need to have a cert at all and this is verified by me being able to run the app from Xcode.


  • stesvisstesvis USMember ✭✭✭✭

    Hi, I am totally new to Xamarin and iOS, but I HAVE to build an app for my company.
    I get the same error when I build the solution (HelloWorld iPhone).
    Could you tell me the exact steps to make it work?
    I don't know what "connect my certificate to Xcode through the organizer" even means...


  • JonElsterJonElster USMember

    What's the solution to this?

  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai


    Have you looked at this tutorial?

    If you are starting fresh, that should help you get things set up correctly.

  • JasonHNYCJasonHNYC USMember, University

    FYI - Once I ensured the profile was in my Mac OS X keychain, it worked fine for me.

  • DeanChalkDeanChalk GBMember ✭✭

    This has just happened to me, was happily building and debugging in Xamarin Studio with the emulator, then suddenly I get this error. I'm on the train and don't have much of an internet connection or IPhone to hand, so now I've wasted 2 hours of development time because I cant do anything. What is it that Xamarin Studio suddenly and inexplicably 'does' to create this random requirement, at a random moment - sigh!

  • RobertVignatoRobertVignato USMember

    @Kevin Mullins - Regarding the 5th bullet point in you post: "Click the View Details... button."

    My account is listed the "View Details" is disabled. Any ideas?

  • ronjacobsronjacobs USMember ✭✭

    My View Details button was disabled too... when I logged into the apple developer site, it suddenly became available.

  • MattBenicMattBenic ZAMember ✭✭

    Thanks @KMullins‌ your post was a big help. In my case the developer identity was there, but missing a private key. Adding it again sorted that out (though to anyone reading this note that the "missing private key" status won't update until you click "Done" and then re-enter the "More details.." pane).

  • JeffTemple.9867JeffTemple.9867 USMember, University

    My variation on this problem is getting the emulator to run on initial build. I do not need to sign up for the developer account. What I did need was to correctly configure Visual Studio.

  • JohnPorembaJohnPoremba USMember

    I have the same issue I can't seem to solve. I followed KMullins list as well as the other suggestions.

    Here is where I am:
    I have a MacMini and an iOS developer license and can build a simple test app on XCode and deploy it to an iPod device. This Works fine.
    I've built the Hello.iOS app using Xamarin Studio on the Mac deployed to the simulator. Works fine.
    I try to build the Hello.iOS app for the iPod device: "No valid iPhone code signing keys found in keychain"

    Any ideas why I can build and deploy for a physical device in xcode but not Xamarin?

  • JohnPorembaJohnPoremba USMember

    Found the fix. I had to delete all the certificates and keys and manually recreate them following the procedure under certificates on the apple developer site (first request the keys via the Mac Keychain tool, then request certificates for the keys. Seems to work for development. Not sure about distribution yet...

  • SudeshSubbaSudeshSubba USUniversity


    So I a newbie and just installed Xamarin and tried to run Tasky in a simulator. I get the code signing error even when I am running it in the simulator. Any idea why its asking for this? Do I need to have a provisioning profile even to running it in the simulator? Really frustrating.

    Building: Tasky.Core.iOS (Debug)
    Performing main compilation...
    Skipping project since output files are up to date
    Build complete -- 0 errors, 0 warnings

    Building: TaskyiOS (Debug|iPhoneSimulator)

    Detecting signing identity...

    ---------------------- Done ----------------------

    No valid iPhone code signing keys found in keychain.
    Build: 1 error, 0 warnings

  • lshieldslshields USMember

    I just installed latest Xamarin on my Mac and get the same error when I try to run Active Configuration iPhone using Debug|iPhoneSimulator.

    Xamarin Studio
    Version 5.5.4 (build 15)
    Mono 3.10.0 ((detached/92c4884)
    GTK+ 2.24.23 (Raleigh theme)
    Package version: 310000031

    Apple Developer Tools
    Xcode 4.6.3 (2068)
    Build 4H1503


    Version: (Starter Edition)
    Android SDK: /Users/me/Library/Developer/Xamarin/android-sdk-macosx
    Supported Android versions:
    2.1 (API level 7)
    2.2 (API level 8)
    2.3 (API level 10)
    3.1 (API level 12)
    4.0.3 (API level 15)
    4.4 (API level 19)
    Java SDK: /usr
    java version "1.7.0_71"
    Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
    Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

    Version: (Starter Edition)
    Hash: 7244769
    Build date: 2014-12-11 14:54:30-0500

    Operating System
    Mac OS X 10.7.5

  • SudeshSubbaSudeshSubba USUniversity

    The "No valid iPhone code signing keys found in keychain." issue looks like is related to the Xamarin installation. If there is an earlier version in your mac and if you install the latest version as a update, the error persists. I un-installed Xamarin completely, then re-installed a fresh version, the error is gone. Looks like the latest version has some installation bugs within it if an update is done.

  • lshieldslshields USMember

    Ok, I was able to get mine working. I had to select my project under the Xamarin solution explorer. Then right-click and select "options". Under project options, "Build", "iOS Application", "iOS Application Target", change setting "Deployment Target" from "7.0" (this was default on my fresh Xamarin install, not an upgrade), to "6.1". My understanding is that 6.1 is latest iOS SDK supported under OS X 10.7.5 (Lion).

    Once you make this change, you can change "device target" from "iOS Device" to iOS Simulator target of iPhone / iPad running iOS version 6.1. After you make that change you will notice that under "Project" menu, "Active Configuration" it finally switches from "Debug|iPhone" to "Debug|iPhoneSimulator". Now when I build / run my project, it will successfully launch in simulated run environment.

    Installed: Xamarin Studio Version 5.5.4 (build 15) / Xamarin.iOS Version: (Starter Edition)
    Operating System: Mac OS X 10.7.5 (Lion)
    Apple Developer Tools: Xcode 4.6.3 (2068) Build 4H1503 (latest Xcode version supported on Lion)

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    For users seeing this issue when deploying to the simulator after updating to Xamarin Studio 5.7 on Mac note that there is a new issue with iOS simulator builds in Xamarin Studio 5.7. Further discussion of that issue can be found here:

    For users seeing this issue when deploying to the simulator after updating to XamarinVS 3.9 on Windows, note that there is a known change in XamarinVS that can require users to remove the <CodesignEntitlements>Entitlements.plist</CodesignEntitlements> element from the .csproj. See also the "Known Issues" in the release notes:

  • DquaglioDquaglio ITMember

    @KMullins Hi, I'm working for a Company and I'm using its DeveloperAccount so i'd like to do only the necessary, you said:

    Click the View Details... button.
    Under the Signing Identities list, click the + button.
    Select iOS Development from the popup list, Xcode will contact Apple and issue a new license which will appear in the Signing Identities list.
    Next click on the + button again and select iOS Distribution from the popup list.
    Again, Xcode will contact Apple, issue a new license and display it in the Signing Identities list.

    Now, on xamarin studio, when I select the drop down menu for Signing Identity it is not listed the company's Identity but only the ones that I normally use. If I go on xcode in the Company "View Details " the signing identities is empty, meanwhile there are items under provisioning profiles. Should I follow your procedure? Also, the "issue a new license" will create something new? or it will download one that already exists?

  • CodemannDealsCodemannDeals USMember

    I am getting the error iOS code signing key '...' not found in keychain. My developer account is valid till next year, this same key worked fine last week.
    Is there any issue with xamarin accessing developer identity/profile? I have restarted VS, restarted my PC, restarted my Mac but this problem persists and it blocking me.

    I am also seeing Unable to copy file 'C....' to 'bin...'. the process cannot access the file ... because it is being used by another process. Delete the bin/obj folder and/or re-starting VS fixes this but it is a pain.


  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    My developer account is valid till next year, this same key worked fine last week.

    The individual signing certificates have individual expiration dates that are not directly tied to your subscription expiration date. Be sure to double-check that all of the individual certificates in the Keychain Access app are still valid.

  • JacobPoulsen_JacobPoulsen_ DKMember ✭✭✭

    Im also experincing this very same issue as @CodemannDeals .
    Nothing seems to be fixing the issue and i've been working on this all day, trying to figure out what the problem is.
    Refreshed every single Provisoning profile, certificate and AppId but nothing changes.
    The issue started after trying to add Push Notifications to my app and therefore having to regenerate my provisioning profiles.

    Anybody else been seeing this issue lately?

  • d87Manishd87Manish USMember
    edited September 2015

    Thanks a lot @M.RIYAZ

    Solved my problem which is the same using simulator.

  • xman10xman10 USMember ✭✭

    same issue when building the sample "WorkingWithListviewNative" on Mac whith Xcode 7.0.1 and Xamarin 5.9.7 Xamarin.iOS

    Other projects just worked fine.

  • I am facing the same issue after upgrading to Xamarin Studio 6.1.5 (build 0). Any solution would be appreciated. By the way I added my apple id in Xcode, but the issue still exists.

  • I had this problem with the latest XamarinCRM iOS app.
    I had to remove the Entitlements.plist in the project options, as someone above mentioned. This allowed it to build and I was able to use the demo version of the app.

  • GaneshGanboteGaneshGanbote USMember ✭✭

    Hi ,

    I am not able to see Provision Profile in Xamarin studio in mac.
    When I tried to add apple developer account in Xamarin studio I got error. Below are the steps in details.

    After entering apple id and password through fastlane , I am geting another box to enter login key chain password.
    After entering login key chain password, I am getting following error.

    Error - Adding Account - 'Account Name'
    Failed to parse PList data type:

    Xamrin Studio : 6.3
    Xcode 9.0

    I am able to login to xcode with apple Id and my all cerificate and Provision profile is valid.

    Kindly reply.

  • PekationPekation PEMember ✭✭

    @anji22 said:
    Solution For:-No valid iOS code signing keys found in keychain

    On the Xamarin forums I found the following solution that worked for me:

    -->Open your Xamarin.Forms projects.
    -->Unload the iOS project in Visual Studio.
    -->Open the csproj file and search for the following element.


    Remove ‘Entitlements.plist’ from the ‘CodesignEntitlements’

    this worked for me. Thanks a lot.

Sign In or Register to comment.