Forum Xamarin.Android

Breakpoints not being hit for Android and Xamarin Forms



  • Vaka.GopiNadhReddyVaka.GopiNadhReddy USMember ✭✭✭


    the problem is with mono 5, so you have to download mono 4.8.1, then install it

  • MohamedElhefnawyMohamedElhefnawy USMember ✭✭

    @Vaka.GopiNadhReddy Thanks in advance

    Can you please provide us link to download Mono 4.8.1 as well as is this workaround doable for xamarin for Visual studio Win 10 not MAC as well as not xamarin studio !

  • Vaka.GopiNadhReddyVaka.GopiNadhReddy USMember ✭✭✭


    i using xamarin studio in mac, it works for me.

    link for mono 4.8.1(for windows and mac):

    **for Visual studio Win 10: **

    follow this post

    Rolling back to 15.0 is the recommended fix for Visual studio.

  • BradChase.2654BradChase.2654 USMember ✭✭✭

    @Vaka.GopiNadhReddy Thanks for all that Vaka.

  • dinobdinob USUniversity ✭✭✭

    It is amazing how useless these forums can be

  • Naveen9453Naveen9453 USMember ✭✭
    edited May 2017

    Sometimes this issue may occurs because of your folder name.
    I was facing this issue from 2 days because i placed my project root folder inside a folder with same name of my project root folder name.

    i.e. My project folder name is MessaginApp (which contains your sub project folder i.e. MessagingApp.Core,MessagingApp.Droid,MessagingApp.iOS)

    and i placed this folder MessagingApp inside folder with name MessagingApp.
    That causes not hitting breakpoints and i am not able to debug my project . When i placed MessagingApp folder not inside with same name folder then i am able to debug and hitting breakpoints.

  • KaiWKaiW DEUniversity ✭✭
    edited June 2017

    Fortunately (in my case) you have Visual Studio and Xamarin Studio. While everything worked fine in most projects, I had one project which did not hit the breakpoints in Xamarin Studio for Android (iOS worked fine). Running the same project in Visual Studio for Mac "fixed" the problem, now breakpoints are hit.

  • techfooninjatechfooninja Member ✭✭

    Visual Studio 2017 running Xamarin Forms - the solution for me was just to delete the bin and obj directories from my Android project. I imagine it's because there's a stale debugging binding that doesn't get re-built on it's own.

  • TopcatTorfsTopcatTorfs Member

    remove bin, obj, the app and also the mono runtime.
    then still failed. i had to enable the "Use shared runtime" in project settings -android options again.
    Then it worked for me on VS2019

Sign In or Register to comment.