debug session not start when I hit F5 for hello world project

I am new for Xamarin. Today I started to download Xamarin.Android and ran on my Windows 7 plus VS 2012 with update 2. When I created a new Android project, set the breakpoint and hit F5, the application was deployed to simulator but the debug session ended. nothing happen and the application was not launched.

What I expect is the application was going to launch after deployed but it was not. The problem happened on both VS 2012 and Xamarin Studio. any idea?

Posts

  • DeanEllisDeanEllis USXamarin Team Xamurai

    can you post the output of the output window in VS/XS and the results from

    adb logcat

    Then we'll be able to get a look at what might be happening.

  • BrunoLatteBrunoLatte USMember
    edited May 2013

    I had the same issue. After installing the latest beta (4.7.04014), I got an exception:
    Mono.Debugging.Soft.ConnectionException: Could not connect to the debugger. ---> System.IO.IOException: DWP Handshake failed. (see monodroid.log attachement)

    I had to start the app on my android device, without debugging.
    The app still crashes, but after that the debugging from VS2012 worked.

    --edit--
    It doesn't always seem to work :(
    A Release build does create a working app on the device.

  • BrunoLatteBrunoLatte USMember

    Can't seem to edit my own post twice (?).

    Anyway, this seems to work:
    1. Clean Solution
    2. Rebuild Solution
    3. Start debug (crashes)
    4. Start debug again. Success. (always seems to need 2 try's)

  • DeanEllisDeanEllis USXamarin Team Xamurai

    ok looks like you are hitting an issue where the override directory does not get created in time. This is a known issue that has been fixed and will be in the next release.

    In the meantime you can try turning Fast Deployment off, or continue to use the process listed above.

  • JonathanPryorJonathanPryor USXamarin Team Xamurai

    the application was deployed to simulator but the debug session ended.

    That might be a variation on Bug 11780. This should be in the stable 4.6.6 release.

  • EnterpriseEnterprise TWMember

    Thanks you guys. I follow BrunoLatte and Dellis's method(Turning off fast deployment) and the issue had been resolved. Thanks again and looking forward for the next release. :)

  • JulienGJulienG USMember

    I just updated my phone from Android 4.X to 5.0.2
    and I encounter this issue:

    I tried to deactivate "fast deployement" option, but doesn't work for me.
    I have a LG G2-mini phone..

    So actually I cannot debug on my android device (but I can execute the app after this one is being deployed)...

    Any news ?
    Thanks

Sign In or Register to comment.